RHEL 5:java-1.7.0-openjdk (RHSA-2015:0068) (POODLE)

medium Nessus 插件 ID 80881
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Red Hat 主机缺少一个或多个安全更新。

描述

更新后的 java-1.7.0-openjdk 程序包修复了多种安全问题,现在可用于 Red Hat Enterprise Linux 5。

Red Hat 产品安全团队将此更新评级为具有重要安全影响。可从“参考”部分中的 CVE 链接获取针对每个漏洞的通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

java-1.7.0-openjdk 程序包提供 OpenJDK 7 Java Runtime Environment 和 OpenJDK 7 Java 软件开发工具包。

在 OpenJDK 中的 Hotspot 组件验证类文件中的字节码的方式中发现一个缺陷。不受信任的 Java 应用程序或小程序可能利用此缺陷绕过 Java 沙盒限制。
(CVE-2014-6601)

在 OpenJDK 的 JAX-WS 和 RMI 组件中发现多个权限检查不当问题。不受信任的 Java 应用程序或小程序可利用这些缺陷绕过 Java 沙盒限制。
(CVE-2015-0412、CVE-2015-0408)

在 Hotspot 垃圾回收器处理虚拟引用的方式中发现一个缺陷。不受信任的 Java 应用程序或小程序可利用此缺陷损坏 Java 虚拟机内存、执行任意代码并绕过 Java 沙盒限制。
(CVE-2015-0395)

在 OpenJDK 的安全组件中的 DER(可辨别编码规则)解码器处理负长度值的方式中发现一个缺陷。特别构建的、以 DER 编码的输入可造成 Java 应用程序在解码时进入无限循环。(CVE-2015-0410)

当解密使用密码块链接 (CBC) 模式下的块加密方式进行加密的消息时,在 SSL 3.0 协议处理填充字节的方式中发现一个缺陷。此缺陷可能允许中间人 (MITM) 攻击者使用 padding oracle 攻击解密密码文本的部分内容。(CVE-2014-3566)

注意:此更新默认禁用 SSL 3.0 以解决此问题。
如果需要,可使用 jdk.tls.disabledAlgorithms 安全属性重新启用 SSL 3.0 支持。有关附加信息,请参阅“参考”部分中链接的 Red Hat Bugzilla 漏洞相关内容。

已发现 OpenJDK 的 JSSE 组件中的 SSL/TLS 实现在 SSL/TLS 连接握手期间未正确检查是否收到 ChangeCipherSpec。
MITM 攻击者可能利用此缺陷在未启用加密的情况下强制建立连接。(CVE-2014-6593)

在 OpenJDK 的 Swing 组件中发现信息泄漏缺陷。
不受信任的 Java 应用程序或小程序可利用此缺陷绕过某些 Java 沙盒限制。(CVE-2015-0407)

在 OpenJDK 的 Libraries 组件的 MulticastSocket 实现中发现空指针取消引用缺陷。不受信任的 Java 应用程序或小程序可能利用此缺陷绕过某些 Java 沙盒限制。(CVE-2014-6587)

在 OpenJDK 的 2D 组件中的字体解析代码中发现多种边界检查缺陷。特别构建的字体文件可允许不受信任的 Java 应用程序或小程序泄露 Java 虚拟机内存的部分内容。(CVE-2014-6585、CVE-2014-6591)

在 OpenJDK 的 Hotspot 组件创建性能统计数据和错误日志文件的方式中发现多种不安全的临时文件使用问题。本地攻击者可能通过符号链接攻击,令使用 OpenJDK 的受害者覆盖任意文件。(CVE-2015-0383)

CVE-2015-0383 问题由 Red Hat 发现。

建议所有 java-1.7.0-openjdk 用户升级这些更新后的程序包,其中解决了这些问题。必须重新启动所有正在运行的 OpenJDK Java 实例,才能使更新生效。

解决方案

更新受影响的数据包。

另见

https://bugzilla.redhat.com/show_bug.cgi?id=1152789#c82

https://access.redhat.com/errata/RHSA-2015:0068

https://access.redhat.com/security/cve/cve-2014-3566

https://access.redhat.com/security/cve/cve-2015-0408

https://access.redhat.com/security/cve/cve-2015-0407

https://access.redhat.com/security/cve/cve-2014-6601

https://access.redhat.com/security/cve/cve-2015-0395

https://access.redhat.com/security/cve/cve-2015-0383

https://access.redhat.com/security/cve/cve-2015-0410

https://access.redhat.com/security/cve/cve-2014-6591

https://access.redhat.com/security/cve/cve-2014-6593

https://access.redhat.com/security/cve/cve-2014-6587

https://access.redhat.com/security/cve/cve-2015-0412

https://access.redhat.com/security/cve/cve-2014-6585

插件详情

严重性: Medium

ID: 80881

文件名: redhat-RHSA-2015-0068.nasl

版本: 1.20

类型: local

代理: unix

发布时间: 2015/1/21

最近更新时间: 2019/10/24

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: Medium

分数: 6.5

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.8

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 6.8

时间分数: 6.1

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:redhat:enterprise_linux:java-1.7.0-openjdk, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-openjdk-debuginfo, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-openjdk-demo, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-openjdk-devel, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-openjdk-javadoc, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-openjdk-src, cpe:/o:redhat:enterprise_linux:5

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可利用: true

易利用性: Exploits are available

补丁发布日期: 2015/1/20

参考资料信息

CVE: CVE-2014-3566, CVE-2014-6585, CVE-2014-6587, CVE-2014-6591, CVE-2014-6593, CVE-2014-6601, CVE-2015-0383, CVE-2015-0395, CVE-2015-0407, CVE-2015-0408, CVE-2015-0410, CVE-2015-0412

BID: 70574, 72132, 72136, 72140, 72142, 72155, 72162, 72165, 72168, 72173, 72175

RHSA: 2015:0068