RHEL 6:rhev-hypervisor6 (RHSA-2011:1850)

medium Nessus 插件 ID 79281
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Red Hat 主机缺少一个或多个安全更新。

描述

更新后的 rhev-hypervisor6 程序包修复了一个安全问题和两个缺陷,现在可用。

Red Hat 安全响应团队已将此更新评级为具有重要安全影响。可从“参考”部分中的 CVE 链接获取通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

rhev-hypervisor6 程序包提供 Red Hat Enterprise Virtualization 管理程序 ISO 磁盘镜像。Red Hat Enterprise Virtualization 管理程序是专用的基于内核的虚拟机 (KVM) 管理程序。它包括运行和管理虚拟机所需的全部内容:Red Hat Enterprise Linux 操作环境的子集和 Red Hat Enterprise Virtualization 代理。

注意:Red Hat Enterprise Virtualization 管理程序仅适用于含虚拟化扩展的 Intel 64 和 AMD64 架构。

使用 SG_IO IOCTL 向分区或 LVM 卷发出 SCSI 请求会导致请求传递到底层区块设备。如果特权用户仅拥有单个分区或 LVM 卷的访问权限,则他们可利用此缺陷绕过这些限制,并获得整个块设备的读写访问权限(并能够发出其他 SCSI 命令)。

在使用由分区或 LVM 卷提供支持的原始格式 virtio 磁盘的 KVM(基于内核的虚拟机)环境中,特权客户机用户可绕过预期的限制并在主机上发出读取和写入请求(以及其他 SCSI 命令),并可能访问驻留于相同底层块设备的其他访客的数据。请参阅 Red Hat Bugzilla 缺陷 752375,获取进一步详细信息以及针对无法立即应用此更新后的用户的缓解脚本。
(CVE-2011-4127)

此更新后的程序包提供更新后的组件,其中包括针对各种安全问题的补丁。但是,这些问题对 Red Hat Enterprise Virtualization 管理程序本身没有安全影响。可使用此更新中包含的安全补丁处理以下 CVE 编号:

CVE-2011-4539(dhcp 问题)

CVE-2011-4339(ipmitool 问题)

CVE-2011-1530(krb5 问题)

此更新还修复以下缺陷:

* 接受含有空格的虚拟 LAN (VLAN) 标识符,即使无法正确地配置它们。通过此更新,拒绝含有空格的 VLAN 标识符并显示“Invalid VLAN ID”消息。(BZ#761537)

* 配置 netconsole 之后,无法启动服务:“service netconsole start”命令失败,显示一条无法找到 configfs.ko 的警告和一个无法插入 netconsole.ko 的致命错误。通过此更新,netconsole 服务按预期启动。请注意,配置 netconsole 之后,服务将不会自动启动,即使重新启动之后也是如此。必须手动启动服务。(BZ#765898)

建议 Red Hat Enterprise Virtualization 管理程序的用户升级此更新后的程序包,其中修正了这些问题。

解决方案

更新受影响的 rhev-hypervisor6 和/或 rhev-hypervisor6-tools 程序包。

另见

https://access.redhat.com/security/cve/cve-2011-4127

https://bugzilla.redhat.com/show_bug.cgi?id=752375

https://access.redhat.com/errata/RHSA-2011:1850

插件详情

严重性: Medium

ID: 79281

文件名: redhat-RHSA-2011-1850.nasl

版本: 1.8

类型: local

代理: unix

发布时间: 2014/11/17

最近更新时间: 2021/1/14

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: Medium

分数: 5.8

CVSS v2

风险因素: Medium

基本分数: 4.6

矢量: AV:L/AC:L/Au:N/C:P/I:P/A:P

漏洞信息

CPE: p-cpe:/a:redhat:enterprise_linux:rhev-hypervisor6, p-cpe:/a:redhat:enterprise_linux:rhev-hypervisor6-tools, cpe:/o:redhat:enterprise_linux:6

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

补丁发布日期: 2011/12/22

漏洞发布日期: 2012/7/3

参考资料信息

CVE: CVE-2011-4127

RHSA: 2011:1850