Debian DSA-2534-1:postgresql-8.4 - 多个漏洞

medium Nessus 插件 ID 61662
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Debian 主机缺少与安全相关的更新。

描述

在 SQL 数据库 PostgreSQL 中发现两个与 XML 处理相关的漏洞。

- CVE-2012-3488 contrib/xml2 的 xslt_process() 可用于读取和写入外部文件及 URL。

- CVE-2012-3489 xml_parse() 提取外部文件或 URL 以解析 XML 值中的 DTD 和实体引用。

此更新删除有问题的功能,从而可能对以合法方式使用该功能的应用程序造成破坏。

由于这些漏洞的性质,对数据库仅可进行间接访问的攻击者可以提供构建的 XML 数据,这些数据会利用此漏洞。

解决方案

升级 postgresql-8.4 程序包。

对于稳定发行版本 (squeeze),已在版本 8.4.13-0squeeze1 中修复这些问题。

另见

https://security-tracker.debian.org/tracker/CVE-2012-3488

https://security-tracker.debian.org/tracker/CVE-2012-3489

https://packages.debian.org/source/squeeze/postgresql-8.4

https://www.debian.org/security/2012/dsa-2534

插件详情

严重性: Medium

ID: 61662

文件名: debian_DSA-2534.nasl

版本: 1.18

类型: local

代理: unix

发布时间: 2012/8/27

最近更新时间: 2021/1/11

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: Medium

分数: 4

CVSS v2

风险因素: Medium

基本分数: 4.9

时间分数: 3.6

矢量: AV:N/AC:M/Au:S/C:P/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:postgresql-8.4, cpe:/o:debian:debian_linux:6.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2012/8/25

参考资料信息

CVE: CVE-2012-3488, CVE-2012-3489

BID: 55072, 55074

DSA: 2534