Debian DSA-4945-1:webkit2gtk - 安全更新

high Nessus 插件 ID 152138

简介

远程 Debian 主机上缺少一个或多个与安全性相关的更新。

描述

远程 Debian 10 主机上安装的多个程序包受到 dsa-4945 公告中提及的多个漏洞影响。

- 在 Webkit WebKitGTK 2.30.4 中,为 ImageLoader 对象处理某些事件的方式中存在释放后使用漏洞。攻击者利用特别构建的网页,可能造成信息泄漏,并进一步损坏内存。攻击者必须诱骗受害者访问恶意网页,才能触发该漏洞。(CVE-2021-21775)

- 在 WebKitGTK 2.30.4 中,Webkits GraphicsContext 处理某些事件的方式中存在释放后使用漏洞。攻击者利用特别构建的网页,可能造成信息泄漏,并进一步损坏内存。攻击者必须诱骗受害者访问恶意网页,才能触发该漏洞。
(CVE-2021-21779)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级 webkit2gtk 程序包。

对于稳定发行版本 (buster),这些问题已在 2.32.3-1~deb10u1 版本中解决。

另见

https://security-tracker.debian.org/tracker/source-package/webkit2gtk

https://www.debian.org/security/2021/dsa-4945

https://security-tracker.debian.org/tracker/CVE-2021-21775

https://security-tracker.debian.org/tracker/CVE-2021-21779

https://security-tracker.debian.org/tracker/CVE-2021-30663

https://security-tracker.debian.org/tracker/CVE-2021-30665

https://security-tracker.debian.org/tracker/CVE-2021-30689

https://security-tracker.debian.org/tracker/CVE-2021-30720

https://security-tracker.debian.org/tracker/CVE-2021-30734

https://security-tracker.debian.org/tracker/CVE-2021-30744

https://security-tracker.debian.org/tracker/CVE-2021-30749

https://security-tracker.debian.org/tracker/CVE-2021-30758

https://security-tracker.debian.org/tracker/CVE-2021-30795

https://security-tracker.debian.org/tracker/CVE-2021-30797

https://security-tracker.debian.org/tracker/CVE-2021-30799

https://packages.debian.org/source/buster/webkit2gtk

插件详情

严重性: High

ID: 152138

文件名: debian_DSA-4945.nasl

版本: 1.5

类型: local

代理: unix

发布时间: 2021/7/29

最近更新时间: 2022/1/18

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: High

分数: 8.4

CVSS v2

风险因素: High

基本分数: 9.3

时间分数: 8.1

矢量: AV:N/AC:M/Au:N/C:C/I:C/A:C

时间矢量: E:H/RL:OF/RC:C

CVSS 分数来源: CVE-2021-30799

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 8.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-4.0, p-cpe:/a:debian:debian_linux:gir1.2-webkit2-4.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-18, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-bin, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-dev, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-37, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-37-gtk2, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-dev, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-doc, p-cpe:/a:debian:debian_linux:webkit2gtk-driver, cpe:/o:debian:debian_linux:10.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/7/28

漏洞发布日期: 2021/4/29

CISA 已知利用日期: 2021/11/17

参考资料信息

CVE: CVE-2021-21775, CVE-2021-21779, CVE-2021-30663, CVE-2021-30665, CVE-2021-30689, CVE-2021-30720, CVE-2021-30734, CVE-2021-30744, CVE-2021-30749, CVE-2021-30758, CVE-2021-30795, CVE-2021-30797, CVE-2021-30799