Debian DSA-4487-1:neovim - 安全更新

high Nessus 插件 ID 126968

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Debian 主机缺少与安全相关的更新。

描述

用户“Arminius”发现,增强版的标准 UNIX 编辑器 Vi (Vi Improved) Vim 中存在漏洞,此漏洞还会影响到 Neovim 分叉(一种聚焦于现代代码和功能的可扩展编辑器):编辑器通常会提供一种方式嵌入编辑器配置命令(又称为 modelines),当打开文件时就会执行,而沙盒机制会过滤有害的命令。据发现,“source”命令(用于加载和执行另一个文件)未受到过滤,通过在 Neovim 中打开精心构建的文件可能会造成 shell 命令执行。

解决方案

升级 neovim 程序包。对于旧稳定发行版本 (stretch),已在版本 0.1.7-4+deb9u1 中修复此问题。

另见

https://packages.debian.org/source/stretch/neovim

https://www.debian.org/security/2019/dsa-4487

插件详情

严重性: High

ID: 126968

文件名: debian_DSA-4487.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2019/7/24

最近更新时间: 2019/8/12

依存关系: ssh_get_info.nasl

风险信息

VPR

风险因素: High

分数: 8.1

CVSS v2

风险因素: High

基本分数: 9.3

时间分数: 7.3

矢量: AV:N/AC:M/Au:N/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.6

时间分数: 7.7

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:neovim, cpe:/o:debian:debian_linux:9.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2019/7/23

漏洞发布日期: 2019/6/5

参考资料信息

CVE: CVE-2019-12735

DSA: 4487