Tenable Log Correlation Engine (LCE) < 4.8.1 Multiple Vulnerabilities

critical Nessus 插件 ID 97893
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机上安装的数据聚合应用程序受到多个漏洞影响。

描述

远程主机上安装的 Tenable Log Correlation Engine (LCE) 版本低于 4.8.1。因而会受到以下漏洞的影响:- 由于未正确逃离作为模板的取消引用属性所传递的输入,Handlebars 库的 lib/handlebars/utils.js 脚本中存在多个跨站脚本 (XSS) 漏洞。未经身份验证的远程攻击者可利用这些漏洞,通过特制的请求,在用户浏览器会话中执行任意脚本代码。(CVE-2015-8861, CVE-2015-8862) - Perl-Compatible Regular Expressions (PCRE) 组件中存在基于堆的缓冲区溢出情况,处理复制命名群组中的嵌套向后引用时会触发。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2016-1283) - 由于未正确分析 XML 文件中的字符,libxml2 组件的 parserInternals.c 中存在越界读取错误。未经身份验证的远程攻击者可利用此问题,泄露敏感信息或造成拒绝服务情况。(CVE-2016-1833) - 处理含有空值的字符串时,由于未正确验证用户提供的输入,libxml2 组件的 xmlstring.c 中存在溢出情况。未经身份验证的远程攻击者可利用此问题,通过特制的文件,造成拒绝服务情况或执行任意代码。(CVE-2016-1834) - libxml2 组件的 parser.c 中存在多个释放后使用错误,分析复杂名称时会触发。未经身份验证的远程攻击者可利用这些问题,通过特制的文件,取消引用已释放内存并可能执行任意代码。(CVE-2016-1835, CVE-2016-1836) - 分析某范围内的字符时,由于未正确验证用户提供的输入,libxml2 组件的 HTMLparser.c 和 xmlregexp.c 中存在多个基于堆缓冲区溢出情况。未经身份验证的远程攻击者可利用这些问题,通过特制的文件,造成拒绝服务情况或执行任意代码。(CVE-2016-1837, CVE-2016-1839, CVE-2016-1840) - libxml2 组件的 parser.c 中存在多个越界读取错误。未经身份验证的远程攻击者可利用这些问题,泄露敏感信息或造成拒绝服务情况。(CVE-2016-1838, CVE-2016-4447) - OpenSSL 组件中文件 crypto/evp/encode.c 内的 EVP_EncodeUpdate() 函数中存在堆缓冲区溢出情况,处理大量输入数据时会触发。未经身份验证的远程攻击者可利用此问题造成拒绝服务。(CVE-2016-2105) - OpenSSL 组件中文件 crypto/evp/evp_enc.c 内的 EVP_EncryptUpdate() 函数中存在堆缓冲区溢出情况,在前一次调用使用部分区块调用相同函数之后,处理大量输入数据时会触发。未经身份验证的远程攻击者可利用此问题造成拒绝服务。(CVE-2016-2106) - 文件 crypto/evp/e_aes_cbc_hmac_sha1.c 的 aesni_cbc_hmac_sha1_cipher() 函数和文件 crypto/evp/e_aes_cbc_hmac_sha256.c 的 aesni_cbc_hmac_sha256_cipher() 函数中存在多个缺陷,当连接使用 AES-CBC 密码且服务器支持 AES-NI 时会触发。中间人攻击者可利用这些漏洞,发动 padding oracle 攻击,进而解密网络流量。(CVE-2016-2107) - 尝试编码以负整数表示的零值时,由于发生下溢情况,OpenSSL 组件中的 ASN.1 编码器存在远程代码执行漏洞。未经身份验证的远程攻击者可利用此问题造成内存损坏,因此导致执行任意代码。(CVE-2016-2108) - 由于无效编码造成分配大量内存,当从 BIO 读取 ASN.1 数据时,d2i BIO 函数中存在多个不明缺陷。未经身份验证的远程攻击者可利用这些缺陷,通过资源耗尽造成拒绝服务情况。(CVE-2016-2109) - 处理极长的 ASN1 字符串时,crypto/x509/x509_obj.c 文件的 X509_NAME_oneline() 函数中存在越界读取错误。未经身份验证的远程攻击者可利用此错误泄露堆栈内存的内容。(CVE-2016-2176) - 处理 (*ACCEPT) 谓词时,由于未正确验证用户提供的输入,Perl-Compatible Regular Expressions (PCRE) 组件中存在溢出情况。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2016-3191) - libxml2 组件的 parser.c 中存在缺陷,以恢复模式处理 XML 内容时会发生。未经身份验证的远程攻击者可利用此问题造成堆栈耗尽,从而导致拒绝服务情况。(CVE-2016-3627) - 由于未正确验证用户提供的输入,libxml2 组件的 parser.c 中存在缺陷。未经身份验证的远程攻击者可利用此问题造成堆栈耗尽,从而导致拒绝服务情况。(CVE-2016-3705) - 由于未正确使用字符串格式说明符(如 %s 和 %x),libxml2 组件中存在格式字符串缺陷。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2016-4448) - 由于未正确分析 XML 数据,parser.c 中存在 XML 外部实体注入漏洞。未经身份验证的远程攻击者可利用此问题,通过特制的 XML 数据,泄露任意文件或造成拒绝服务情况。(CVE-2016-4449) - libxml2 组件的 xmlsave.c 中存在越界读取错误,以恢复模式处理 XML 内容时会发生。未经身份验证的远程攻击者可利用此问题,泄露敏感信息或造成拒绝服务情况。(CVE-2016-4483) - 由于即使客户端证书失败,程序还是会尝试恢复 TLS 会话,libcurl 组件中存在安全绕过漏洞。未经身份验证的远程攻击者可利用此问题绕过验证机制。(CVE-2016-5419) - 由于程序重复使用具有不同客户端证书的 TLS 连接,libcurl 组件中存在信息泄露漏洞。未经身份验证的远程攻击者可利用此问题,泄露敏感的跨域信息。(CVE-2016-5420) - libcurl 组件中存在释放后使用错误,未正确清除连接指针以便轻松处理时会触发。未经身份验证的远程攻击者可利用此问题取消引用已释放内存,从而导致执行任意代码。(CVE-2016-5421) - 由于未正确验证用户提供的输入,存在多种存储型跨站脚本 (XSS) 漏洞。经身份验证的远程攻击者可利用这些问题,通过特制的请求,在用户浏览器会话中执行任意脚本代码。(CVE-2016-9261)

解决方案

升级版本到 Tenable LCE 4.8.1 或更高版本。

另见

https://www.tenable.com/security/tns-2016-18

https://www.openssl.org/news/secadv/20160503.txt

插件详情

严重性: Critical

ID: 97893

文件名: lce_4_8_1.nasl

版本: 1.5

类型: local

系列: Misc.

发布时间: 2017/3/22

最近更新时间: 2019/1/2

依存关系: lce_installed.nbin

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.8

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:tenable:log_correlation_engine

必需的 KB 项: installed_sw/Log Correlation Engine Server

可利用: true

易利用性: Exploits are available

补丁发布日期: 2016/10/1

漏洞发布日期: 2015/9/7

参考资料信息

CVE: CVE-2015-8861, CVE-2015-8862, CVE-2016-1283, CVE-2016-1833, CVE-2016-1834, CVE-2016-1835, CVE-2016-1836, CVE-2016-1837, CVE-2016-1838, CVE-2016-1839, CVE-2016-1840, CVE-2016-2105, CVE-2016-2106, CVE-2016-2107, CVE-2016-2108, CVE-2016-2109, CVE-2016-2176, CVE-2016-3191, CVE-2016-3627, CVE-2016-3705, CVE-2016-4447, CVE-2016-4448, CVE-2016-4449, CVE-2016-4483, CVE-2016-5419, CVE-2016-5420, CVE-2016-5421, CVE-2016-9261

BID: 79825, 84810, 84992, 87940, 89744, 89746, 89752, 89757, 89760, 89854, 90013, 90856, 90864, 90865, 92292, 92306, 92309, 96434, 96436