PHP 7.0.x < 7.0.14 多个漏洞

critical Nessus 插件 ID 95875
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 web 服务器上运行的 PHP 版本受到远程代码执行漏洞影响。

描述

根据其标题,远程 web 服务器上运行的 PHP 7.0.x 版本低于 7.0.14。因而会受到以下漏洞的影响:- 由于解码空布尔元素时,ext/wddx/wddx.c 的 php_wddx_push_element() 函数中发生内存损坏问题,因此受到远程代码执行漏洞的影响。未经身份验证的远程攻击者可利用此问题造成拒绝服务情况或执行任意代码。(CVE-2016-9935) - ext/standard/var.c 脚本中存在一个反序列化漏洞。未经身份验证的远程攻击者可利用此问题,通过特制的序列化数据,在目标主机上造成应用程序停止响应或执行任意代码。(CVE-2016-9936) 请注意,Nessus 并未针对这些问题进行测试,而仅依赖应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 7.0.14 或更新版。

另见

http://php.net/ChangeLog-7.php#7.0.14

插件详情

严重性: Critical

ID: 95875

文件名: php_7_0_14.nasl

版本: 1.6

类型: remote

系列: CGI abuses

发布时间: 2016/12/15

最近更新时间: 2019/3/27

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2016-9935

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2016/12/8

漏洞发布日期: 2016/12/6

参考资料信息

CVE: CVE-2016-9935, CVE-2016-9936

BID: 94846, 94849