OpenSSL 1.1.0 < 1.1.0a 多个漏洞

high Nessus 插件 ID 93816
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程服务受到多个漏洞的影响。

描述

根据其标题,远程主机正在运行低于 1.1.0a 的 OpenSSL 1.1.0 版本。因而会受到以下漏洞的影响:- 由于未正确处理客户端的过大 OCSP 状态请求扩展,t1_lib.c 内的 ssl_parse_clienthello_tlsext() 函数中存在缺陷。未经身份验证的远程攻击者可利用此问题,通过大型 OCSP 状态请求扩展,消耗内存资源,进而导致拒绝服务情况。(CVE-2016-6304) - 由于未正确处理空记录,rec_layer_s3.c 内的 SSL_peek() 函数中存在缺陷。未经身份验证的远程攻击者可利用此问题,通过触发 SSL_peek 调用中的零长度记录,造成无限循环,进而导致拒绝服务情况。(CVE-2016-6305) - 由于分配内存之前,未能检查超标长度,状态机实现中存在拒绝服务漏洞。未经身份验证的远程攻击者可利用此问题,通过构建的 TLS 消息,消耗内存资源。(CVE-2016-6307) - 由于未正确处理过长 DTLS 消息,DTLS 实现中存在拒绝服务漏洞。未经身份验证的远程攻击者可利用此问题,通过构建的 DTLS 消息,消耗可用内存资源。(CVE-2016-6308) - 由于使用长期密钥建立加密连接,GOST 密码套件中存在缺陷。中间人攻击者可利用此问题,通过 Key Compromise Impersonation (KCI) 攻击模拟服务器。

解决方案

升级到 OpenSSL 版本 1.1.0a 或更高版本。请注意,供应商尚未在官方发布中修复 GOST 密码套件漏洞;然而,问题的修补程序已经提交至 OpenSSL github 存储库。

另见

https://www.openssl.org/news/secadv/20160922.txt

http://www.nessus.org/u?09b29b30

插件详情

严重性: High

ID: 93816

文件名: openssl_1_1_0a.nasl

版本: 1.8

类型: remote

系列: Web Servers

发布时间: 2016/9/30

最近更新时间: 2019/11/14

依存关系: openssl_version.nasl

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: High

基本分数: 7.8

时间分数: 6.1

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.7

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:openssl:openssl

必需的 KB 项: openssl/port

可利用: true

易利用性: Exploits are available

补丁发布日期: 2016/9/22

漏洞发布日期: 2015/8/10

参考资料信息

CVE: CVE-2016-6304, CVE-2016-6305, CVE-2016-6307, CVE-2016-6308

BID: 93149, 93150, 93151, 93152