Oracle MySQL 5.5.x < 5.5.50 多个漏洞(2016 年 7 月 CPU)

high Nessus 插件 ID 91994

简介

远程主机缺少一个或多个安全更新。

描述

远程主机上安装的 Oracle MySQL 5.5.x 版本低于 5.5.50。因此,它受到以下漏洞的影响:

- Parser 子组件中存在一个不明缺陷,允许本地攻击者取得升级的权限。(CVE-2016-3477)

- Types 子组件中存在一个不明缺陷,允许经认证的远程攻击者造成拒绝服务情况。(CVE-2016-3521)

- DML 子组件中存在一个不明缺陷,允许经认证的远程攻击者造成拒绝服务。(CVE-2016-3615)

- RBR 子组件中存在一个不明缺陷,允许经认证的远程攻击者造成拒绝服务情况。(CVE-2016-5440)

- 存在多个溢位情况,这是因为不当验证用户提供的输入所导致。经认证的远程攻击者可利用这些问题,藉此造成拒绝服务情况或执行任意代码。(VulnDB 139552)

- 解析器结构中存在一个空指针取消引用缺陷,在验证存储的程序名称期间会触发该缺陷。经认证的远程攻击者可利用此问题来造成数据库崩溃,进而导致拒绝服务情况。
(VulnDB 139553)

解决方案

升级到 MySQL 版本 5.5.50 或更高版本。

另见

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-50.html

http://www.nessus.org/u?42cde00c

https://support.oracle.com/rs?type=doc&id=2157431.1

http://www.nessus.org/u?453b5f8c

插件详情

严重性: High

ID: 91994

文件名: mysql_5_5_50_rpm.nasl

版本: 1.10

类型: local

代理: unix

系列: Databases

发布时间: 2016/7/11

最近更新时间: 2020/6/3

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 6.5

CVSS v2

风险因素: Medium

基本分数: 4.1

时间分数: 3

矢量: AV:L/AC:M/Au:S/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2016-3477

CVSS v3

风险因素: High

基本分数: 8.1

时间分数: 7.1

矢量: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:oracle:mysql, p-cpe:/a:amazon:linux:mysql, p-cpe:/a:centos:centos:mysql, p-cpe:/a:fedoraproject:fedora:mysql, p-cpe:/a:fermilab:scientific_linux:mysql, p-cpe:/a:novell:opensuse:mysql, p-cpe:/a:novell:suse_linux:mysql, p-cpe:/a:oracle:linux:mysql, p-cpe:/a:redhat:enterprise_linux:mysql

必需的 KB 项: Host/local_checks_enabled

易利用性: No known exploits are available

补丁发布日期: 2016/6/2

漏洞发布日期: 2016/6/2

参考资料信息

CVE: CVE-2016-3477, CVE-2016-3521, CVE-2016-3615, CVE-2016-5440

BID: 91902, 91932, 91953, 91960