OpenSSL 1.0.1 < 1.0.1r 多种漏洞 (Logjam)

low Nessus 插件 ID 88529

简介

远程服务受到多种漏洞影响。

描述

根据其标题,远程主机正在运行 OpenSSL 1.0.1,该版本早于 1.0.1r。因此,它受到以下漏洞的影响:

- 存在一个加密算法降级漏洞,这是因为处理密码协商时触发的缺陷所导致。远程攻击者可利用此漏洞协商 SSLv2 密码并完成 SSLv2 握手,即使所有 SSLv2 密码都已在服务器上禁用也是如此。请注意,只有在 SSL_OP_NO_SSLv2 选项尚未禁用时,此漏洞才会存在。
(CVE-2015-3197)

- 由于 SSL/TLS 协议中的缺陷,存在中间人漏洞,也称为 Logjam。远程攻击者可利用此缺陷,使用临时 Diffie-Hellman 密钥交换将连接降级至 512 位出口级加密。(CVE-2015-4000)

解决方案

升级到 OpenSSL 版本 1.0.1r 或更高版本。

另见

https://www.openssl.org/news/secadv/20160128.txt

https://weakdh.org/

插件详情

严重性: Low

ID: 88529

文件名: openssl_1_0_1r.nasl

版本: 1.10

类型: remote

系列: Web Servers

发布时间: 2016/2/2

最近更新时间: 2019/11/20

风险信息

CVSS 分数来源: CVE-2015-4000

VPR

风险因素: Low

分数: 3.9

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Low

基本分数: 3.7

时间分数: 3.2

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:openssl:openssl

必需的 KB 项: openssl/port

易利用性: No known exploits are available

补丁发布日期: 2016/1/28

漏洞发布日期: 2016/1/28

参考资料信息

CVE: CVE-2015-3197, CVE-2015-4000

BID: 74733

CERT: 257823