Oracle WebLogic Server Java 对象反序列化 RCE(本地检查)

critical Nessus 插件 ID 87209
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机受到不明漏洞的影响。

描述

远程 Oracle WebLogic 服务器受到 WLS Security 组件中远程代码执行漏洞的影响,这是未经身份验证的 Java 对象对 Apache Commons Collections (ACC) 库进行不安全的反序列化调用所致。未经身份验证的远程攻击者可利用此漏洞在目标主机上执行任意代码。

解决方案

应用临时修补程序 22248372。

另见

http://www.nessus.org/u?e0203be3

http://www.nessus.org/u?9c6d83db

插件详情

严重性: Critical

ID: 87209

文件名: oracle_weblogic_server_cve_2015_4852.nbin

版本: 1.231

类型: local

代理: windows, macosx, unix

系列: Misc.

发布时间: 2015/12/4

最近更新时间: 2021/12/3

依存关系: oracle_weblogic_server_installed.nbin

风险信息

CVSS 分数来源: CVE-2015-4852

VPR

风险因素: Critical

分数: 10

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 10

时间分数: 9.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:oracle:weblogic_server

必需的 KB 项: Oracle/WLS/Installed

可利用: true

易利用性: Exploits are available

补丁发布日期: 2015/11/30

漏洞发布日期: 2015/1/28

可利用的方式

CANVAS (CANVAS)

Core Impact

Metasploit (Oracle Weblogic Server Deserialization RCE - Raw Object)

参考资料信息

CVE: CVE-2015-4852

BID: 77539

CERT: 576313

IAVA: 2015-A-0287