Mac OS X:OS X Server < 5.0.3 多种漏洞

critical Nessus 插件 ID 86066
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程主机缺少 OS X Server 的安全更新。

描述

远程 Mac OS X 主机上安装的 OS X Server 版本低于 5.0.3。因此,它受到以下漏洞的影响:

- mod_headers 模块中允许 HTTP 尾部在处理请求期间替换 HTTP 标头的漏洞。远程攻击者可利用此漏洞注入任意标头。这可能导致某些模块功能出错或显示为功能出错。
(CVE-2013-5704)

- 由于“make check”命令未正确调用 initdb 来为测试中所使用的数据库群集指定认证要求,故存在权限升级漏洞。本地攻击者可利用此问题获取临时服务器访问权限以及升级的特权。(CVE-2014-0067)

- 在 mod_cache 模块中存在空指针取消引用缺陷。远程攻击者使用空 HTTP Content-Type 标头,能够使用此漏洞引起缓存转发代理配置崩溃,导致如果使用线程 MPM 则会拒绝服务。
(CVE-2014-3581)

- 在 mod_proxy_fcgi 模块中存在越界内存读取缺陷。攻击者使用 FastCGI 服务器发送长响应头能够利用此漏洞导致缓冲区过度读取,引起拒绝服务。(CVE-2014-3583)

- 当使用不同参数处理用于多个 Require 指令的 LuaAuthzProvider 时,在 mod_lua 模块中存在缺陷。攻击者可利用此漏洞绕过特意设置的访问限制。
(CVE-2014-8109)

- 由于未正确处理违反限制的错误消息中的受限列值,因而导致存在信息泄露漏洞。经认证的远程攻击者可以利用这一点获取敏感信息的访问权限。(CVE-2014-8161)

- 域名服务中存在缺陷,原因是在用于接受委派的代码中具有错误。拥有恶意构造的区域或查询的远程攻击者可导致服务发出无限制的查询,从而造成资源耗尽。(CVE-2014-8500)

- 由于未正确处理 WebSocket PING 帧,在“mod_lua”模块的 lua_websocket_read() 函数中存在缺陷。远程攻击者可利用此缺陷,在 Lua 脚本调用 wsupgrade() 函数后发送一个构建的 WebSocket PING 帧以造成子进程崩溃,从而导致拒绝服务。(CVE-2015-0228)

- 由于存在与“to_char”函数相关的多个缓冲区溢出错误,因而存在多种漏洞。经认证的远程攻击者可利用这些问题造成拒绝服务或执行任意代码。(CVE-2015-0241)

- 由于各种 *printf() 函数中存在多个基于堆栈的缓冲区溢出错误,因而导致存在多种漏洞。溢出的原因是当请求的精度大约大于 500 时,在格式化浮点数时未正确验证用户提供的输入。经认证的远程攻击者可利用这些问题造成拒绝服务或执行任意代码。(CVE-2015-0242)

- 由于“pgcrypto”扩展的多个函数中存在溢出情况,因而导致存在多种漏洞。溢出的原因是跟踪内存大小时未正确验证用户提供的输入。经认证的远程攻击者可利用这些问题造成拒绝服务或执行任意代码。(CVE-2015-0243)

- 由于在处理命令参数中构建的二进制数据时未正确审查用户提供的输入,导致存在 SQL 注入漏洞。经认证的远程攻击者可利用此问题注入或操纵 SQL 查询,从而允许操纵或泄露任意数据。
(CVE-2015-0244)

由于未能初始化协议结构成员而导致 read_request_line() 函数中存在空指针取消引用缺陷。远程攻击者可利用此缺陷,在启用 INCLUDES 过滤器且包含指定本地 URI 的 ErrorDocument 400 指令的安装下发送缺少方法的请求,以造成拒绝服务。(CVE-2015-0253)

- 由于与 DNSSEC 验证和托管密钥功能相关的错误,存在拒绝服务漏洞。远程攻击者可触发不正确的 trust-anchor 管理情况,其中没有可用的密钥,从而导致断言失败和后台程序崩溃。(CVE-2015-1349)

- PostgreSQL 连接中断超时到期中存在缺陷,当超时中断部分地通过会话关闭序列激活时可触发此缺陷。(CVE-2015-3165)

- printf() 函数中存在因未能检查错误而导致的缺陷。远程攻击者可利用此缺陷获取敏感信息的访问权限。(CVE-2015-3166)

- PostgreSQL 中的 pgcrypto 组件因使用错误密钥解密而具有多种错误消息。远程攻击者可利用此缺陷从其他系统恢复密钥。(CVE-2015-3167)

- 由于未能正确解析区块标头,分块传输编码实现中存在一个缺陷。远程攻击者可利用此缺陷进行 HTTP 请求走私攻击。(CVE-2015-3183)

- 由于未考虑 Require 指令可能与授权设置而非验证设置有关,因此,ap_some_auth_required() 函数中存在一个缺陷。如果存在依赖 2.2 API 行为的模块,远程攻击者可以利用此缺陷绕过预期访问限制。
(CVE-2015-3185)

- 基于 Twisted 的 Wiki Server 中存在多种不明的 XML 缺陷。(CVE-2015-5911)

解决方案

升级到 Mac OS X Server 5.0.3 或更高版本。

请注意:OS X Server 5.0.3 仅可用于 OS X 10.10.5 或更高版本。

另见

https://support.apple.com/en-us/HT205219

http://www.nessus.org/u?b8a8a151

插件详情

严重性: Critical

ID: 86066

文件名: macosx_server_5_0_3.nasl

版本: 1.9

类型: local

代理: macosx

发布时间: 2015/9/22

最近更新时间: 2019/11/22

依存关系: macosx_server_services.nasl

风险信息

CVSS 分数来源: CVE-2015-5911

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.4

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/o:apple:mac_os_x_server

必需的 KB 项: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Server/Version

易利用性: No known exploits are available

补丁发布日期: 2015/9/16

漏洞发布日期: 2015/9/16

参考资料信息

CVE: CVE-2013-5704, CVE-2014-0067, CVE-2014-3581, CVE-2014-3583, CVE-2014-8109, CVE-2014-8161, CVE-2014-8500, CVE-2015-0228, CVE-2015-0241, CVE-2015-0242, CVE-2015-0243, CVE-2015-0244, CVE-2015-0253, CVE-2015-1349, CVE-2015-3165, CVE-2015-3166, CVE-2015-3167, CVE-2015-3183, CVE-2015-3185, CVE-2015-5911

BID: 65721, 66550, 71590, 71656, 71657, 72538, 72540, 72542, 72543, 72673, 73040, 73041, 74787, 74789, 74790, 75963, 75964, 75965

APPLE-SA: APPLE-SA-2015-09-16-4