Apache 2.4.x < 2.4.16 多个漏洞

medium Nessus 插件 ID 84959

简介

远程 Web 服务器受到多个漏洞影响。

描述

根据其标题,远程主机上安装的 Apache 2.4.x 版本低于 2.4.16。因此,该应用程序受到以下漏洞的影响:

- 由于未正确处理 WebSocket PING 帧,在“mod_lua”模块的 lua_websocket_read() 函数中存在缺陷。远程攻击者可利用此缺陷,在 Lua 脚本调用 wsupgrade() 函数后发送一个构建的 WebSocket PING 帧以造成子进程崩溃,从而导致拒绝服务。(CVE-2015-0228)

由于未能初始化协议结构成员而导致 read_request_line() 函数中存在空指针取消引用缺陷。远程攻击者可利用此缺陷,在启用 INCLUDES 过滤器且包含指定本地 URI 的 ErrorDocument 400 指令的安装下发送缺少方法的请求,以造成拒绝服务。(CVE-2015-0253)

- 由于未能正确解析区块标头,分块传输编码实现中存在一个缺陷。远程攻击者可利用此缺陷进行 HTTP 请求走私攻击。(CVE-2015-3183)

- 由于未考虑 Require 指令可能与授权设置而非验证设置有关,因此,ap_some_auth_required() 函数中存在一个缺陷。如果存在依赖 2.2 API 行为的模块,远程攻击者可以利用此缺陷绕过预期访问限制。
(CVE-2015-3185)

- 由于密钥流生成中的初始双字节偏差,RC4 算法中存在一个缺陷。攻击者可利用此缺陷,通过将先验明文发行版本和密钥流发行版本统计数据相结合的 Bayesian 分析,执行密码文本的明文恢复。请注意,根据 RFC 7465 的要求,RC4 加密套件已禁止。Apache 版本 2.4.13 中已修复此问题,但 2.4.13、2.4.14 和 2.4.15 从未公开发行。

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级至 Apache 2.4.16 或更高版本。此为,还需确保没有使用受影响的模块。

另见

https://archive.apache.org/dist/httpd/CHANGES_2.4.16

http://httpd.apache.org/security/vulnerabilities_24.html

http://www.nessus.org/u?7ec9a07a

https://tools.ietf.org/html/rfc7465

插件详情

严重性: Medium

ID: 84959

文件名: apache_2_4_16.nasl

版本: 1.18

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2015/7/23

最近更新时间: 2022/4/11

支持的传感器: Nessus Agent

风险信息

CVSS 分数来源: CVE-2015-3183

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.6

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2015/7/15

漏洞发布日期: 2015/2/3

参考资料信息

CVE: CVE-2015-0228, CVE-2015-0253, CVE-2015-3183, CVE-2015-3185

BID: 73041, 75963, 75964, 75965