Apache Tomcat 7.0.x < 7.0.59 安全管理器绕过

high Nessus 插件 ID 83764

简介

远程 Apache Tomcat 服务器受到安全绕过漏洞的影响。

描述

根据其自我报告的版本号,正在远程主机上监听的 Apache Tomcat 服务器是 7.0.x 且低于 7.0.59。因此,它会受到安全绕过漏洞的影响,原因是处理表达式语言时存在缺陷。远程攻击者可利用此问题,通过构建的 Web 应用程序绕过安全管理器保护,从而执行任意代码。

请注意,Nessus 没有测试此问题,而仅依赖于应用程序自我报告的版本号。

解决方案

升级到 Apache Tomcat 版本 7.0.59 或更高版本。

另见

http://www.nessus.org/u?edd653ec

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.59

https://seclists.org/bugtraq/2015/May/94

插件详情

严重性: High

ID: 83764

文件名: tomcat_7_0_59.nasl

版本: 1.15

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2015/5/21

最近更新时间: 2022/4/11

支持的传感器: Nessus Agent

风险信息

CVSS 分数来源: CVE-2014-7810

VPR

风险因素: Low

分数: 3.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.3

时间分数: 6.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:tomcat

必需的 KB 项: installed_sw/Apache Tomcat

易利用性: No known exploits are available

补丁发布日期: 2015/2/4

漏洞发布日期: 2015/5/14

参考资料信息

CVE: CVE-2014-7810

BID: 74665