Firefox < 37.0 多种漏洞 (Mac OS X)

high Nessus 插件 ID 82500

简介

远程 Mac OS X 主机包含受到多种漏洞影响的 Web 浏览器。

描述

远程 Mac OS X 主机上安装的 Firefox 版本低于 37.0。因此,它受到以下漏洞的影响:

- 存在与定位标记导航相关的权限升级漏洞。远程攻击者可利用此漏洞绕过同源策略保护,从而允许在特权上下文中执行任意脚本。请注意,这是 CVE-2015-0818 的变体,已在 Firefox 36.0.4 中得到修复。
(CVE-2015-0801)

- 当从创建用于包含特权 UI 内容的窗口导航至非特权页面时,保留对特定特权内部方法的访问权限。攻击者可利用此漏洞以升级的权限执行任意 JavaScript。(CVE-2015-0802)

- 存在多个类型混淆问题,可导致释放后使用错误,远程攻击者可利用这些问题执行任意代码或造成拒绝服务。(CVE-2015-0803、CVE-2015-0804)

- 在渲染 2D 图形时,存在与非主线程复合相关的多个内存损坏问题,远程攻击者可利用这些问题执行任意代码或造成拒绝服务。(CVE-2015-0805、CVE-2015-0806)

- 由于 30x 重定向随附的跨源资源共享 (CORS) 请求,sendBeacon() 函数中存在跨站请求伪造 (XSRF) 漏洞。(CVE-2015-0807)

- WebRTC 中存在与简单样式数组的内存管理相关的问题,远程攻击者可利用此问题造成拒绝服务。(CVE-2015-0808)

- 存在允许远程攻击者使用户的光标不可见的问题,可能导致成功的点击劫持攻击。(CVE-2015-0810)

- QCMS 色彩管理库中存在越界读取问题,可导致信息泄露。(CVE-2015-0811)

- 存在可允许中间人攻击者通过欺骗 Mozilla 子域来绕过用户确认并安装 Firefox 轻量级主题的问题。(CVE-2015-0812)

- 浏览器引擎中存在多种内存安全问题。远程攻击者可利用这些问题损坏内存并执行任意代码。
(CVE-2015-0814、CVE-2015-0815)

- 存在与通过“resource:”URL 加载文档相关的权限升级漏洞。攻击者可利用此漏洞加载页面并以升级的权限执行 JavaScript。(CVE-2015-0816)

解决方案

升级到 Firefox 37.0 或更高版本。

另见

https://www.mozilla.org/en-US/security/advisories/mfsa2015-30/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-32/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-33/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-34/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-35/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-36/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-37/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-38/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-39/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-40/

https://www.mozilla.org/en-US/security/advisories/mfsa2015-42/

插件详情

严重性: High

ID: 82500

文件名: macosx_firefox_37.nasl

版本: 1.10

类型: local

代理: macosx

发布时间: 2015/4/1

最近更新时间: 2018/7/14

支持的传感器: Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 6.4

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

漏洞信息

CPE: cpe:/a:mozilla:firefox

必需的 KB 项: MacOSX/Firefox/Installed

可利用: true

易利用性: Exploits are available

补丁发布日期: 2015/3/31

漏洞发布日期: 2014/12/9

可利用的方式

Metasploit (Firefox PDF.js Privileged Javascript Injection)

参考资料信息

CVE: CVE-2015-0801, CVE-2015-0802, CVE-2015-0803, CVE-2015-0804, CVE-2015-0805, CVE-2015-0806, CVE-2015-0807, CVE-2015-0808, CVE-2015-0810, CVE-2015-0811, CVE-2015-0812, CVE-2015-0814, CVE-2015-0815, CVE-2015-0816

BID: 73454, 73455, 73456, 73457, 73458, 73460, 73461, 73462, 73464, 73465, 73466, 73467