PHP 5.4.x < 5.4.39 多种漏洞

critical Nessus 插件 ID 82025
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题栏,远程主机上安装的 PHP 5.4.x 版本低于 5.4.39。因此,它受到多种漏洞的影响:

- 存在与函数“unserialize”相关的释放后使用错误,可允许远程攻击者执行任意代码。请注意,此问题源于对 CVE-2014-8142 的修复不完整。(CVE-2015-0231)

- 由于未正确验证用户提供的输入,因而在 Henry Spencer regex 库的“regcomp”函数中存在整数溢出错误。攻击者可利用此问题造成拒绝服务或执行任意代码。(CVE-2015-2305)

- 由于未正确验证用户提供的输入,因而“_zip_cdir_new”函数中存在整数溢出错误。攻击者可使用构建的 ZIP 存档,利用此错误造成拒绝服务或执行任意代码。(CVE-2015-2331)

- 由于在遇到空字节时 move_uploaded_file() 函数中的路径名称被截断而产生了缺陷,因此存在过滤器绕过漏洞。这允许远程攻击者通过构建的第二参数绕过预期扩展限制并创建带有意外名称的文件。(CVE-2015-2348)

- process_nested_data() 函数中存在一个释放后使用错误。这允许远程攻击者通过特别构建的反序列化调用来取消引用已释放的内存,从而导致执行任意代码。(CVE-2015-2787)

请注意,Nessus 并不试图利用这些问题,而只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.4.39 或更新版。

另见

http://php.net/ChangeLog-5.php#5.4.39

https://bugs.php.net/bug.php?id=69207

https://bugs.php.net/bug.php?id=68976

插件详情

严重性: Critical

ID: 82025

文件名: php_5_4_39.nasl

版本: 1.16

类型: remote

系列: CGI abuses

发布时间: 2015/3/24

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2015-4147

VPR

风险因素: High

分数: 8.8

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 9.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:H/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

可利用: true

易利用性: No exploit is required

补丁发布日期: 2015/3/19

漏洞发布日期: 2014/12/18

参考资料信息

CVE: CVE-2015-0231, CVE-2015-2305, CVE-2015-2331, CVE-2015-2348, CVE-2015-2787, CVE-2015-4147, CVE-2015-4148

BID: 72539, 73182, 73357, 73381, 73383, 73385, 73431, 73434, 75103