Oracle Solaris 第三方修补程序更新:firefox (multiple_vulnerabilities_in_firefox_web)

high Nessus 插件 ID 80606

简介

远程 Solaris 系统缺少第三方软件的安全修补程序。

描述

远程 Solaris 系统缺少用于处理安全更新的必要修补程序:

- Mozilla Firefox 4.x 至 10.0、低于 10.0.3 的 Firefox ESR 10.x、Thunderbird 5.0 至 10.0、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 中存在 CRLF 注入漏洞,允许远程 Web 服务器通过构建的 HTTP 标头绕过预期内容安全策略 (CSP) 限制并进行跨站脚本 (XSS) 攻击。
(CVE-2012-0451)

- 低于 3.6.28 和 4.x 至 10.0 的 Mozilla Firefox、低于 10.0.3 的 Firefox ESR 10.x、低于 3.1.20 和 5.0 至 10.0 的 Thunderbird、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 未正确限制 javascript: URL 上的拖放操作,这允许受用户协助的远程攻击者通过与“DragAndDropJacking”问题相关的构建网页进行跨站脚本 (XSS) 攻击。
(CVE-2012-0455)

- 低于 3.6.28 和 4.x 至 10.0 的 Mozilla Firefox、低于 10.0.3 的 Firefox ESR 10.x、低于 3.1.20 和 5.0 至 10.0 的 Thunderbird、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 中的 SVG 过滤器实现可允许远程攻击者通过触发越界读取的矢量从进程内存中获取敏感信息。(CVE-2012-0456)

- 低于 3.6.28 和 4.x 至 10.0 的 Mozilla Firefox、低于 10.0.3 的 Firefox ESR 10.x、低于 3.1.20 和 5.0 至 10.0 的 Thunderbird、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 中的 nsSMILTimeValueSpec::ConvertBetweenTimeContainer 函数存在释放后使用漏洞,可允许远程攻击者通过 SVG 动画执行任意代码。(CVE-2012-0457)

- 低于 3.6.28 和 4.x 至 10.0 的 Mozilla Firefox、低于 10.0.3 的 Firefox ESR 10.x、低于 3.1.20 和 5.0 至 10.0 的 Thunderbird、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 未正确限制通过将 URL 拖动到主页按钮来设置主页的操作,从而允许受用户协助的远程攻击者通过 javascript: URL(稍后在 about:sessionrestore 上下文中进行解释),以 chrome 权限执行任意 JavaScript 代码。
(CVE-2012-0458)

- Mozilla Firefox 4.x 至 10.0、低于 10.0.3 的 Firefox ESR 10.x、Thunderbird 5.0 至 10.0、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 中的层叠样式表 (CSS) 实现允许远程攻击者通过对某个关键帧进行动态修改之后访问该关键帧的 cssText 造成拒绝服务(应用程序崩溃)或执行任意代码。(CVE-2012-0459)

- Mozilla Firefox 4.x 至 10.0、低于 10.0.3 的 Firefox ESR 10.x、Thunderbird 5.0 至 10.0、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 未正确限制对 window.fullScreen 对象的写入访问,这允许远程攻击者通过构建的网页欺骗用户界面。(CVE-2012-0460)

- 低于 3.6.28和 4.x 至 10.0 的 Mozilla Firefox 、低于 10.0.3 的 Firefox ESR 10.x、低于 3.1.20 的 Thunderbird 和 5.0 至 10.0、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 的浏览器引擎中存在多种不明漏洞,允许远程攻击者通过未知矢量造成拒绝服务(内存损坏和应用程序崩溃)或执行任意代码。(CVE-2012-0461)

- Mozilla Firefox 4.x 至 10.0、低于 10.0.3 的 Firefox ESR 10.x、Thunderbird 5.0 至 10.0、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 的浏览器引擎中存在多种不明漏洞,允许远程攻击者通过未知矢量造成拒绝服务(内存损坏和应用程序崩溃)或执行任意代码。
(CVE-2012-0462)

- 低于 3.6.28 和 4.x 至 10.0 的 Mozilla Firefox、低于 10.0.3 的 Firefox ESR 10.x、低于 3.1.20 和 5.0 至 10.0 的 Thunderbird、低于 10.0.3 的 Thunderbird ESR 10.x 以及低于 2.8 的 SeaMonkey 的浏览器引擎中存在释放后使用漏洞,允许远程攻击者通过将涉及 array.join 函数的空参数的矢量与垃圾回收的触发相结合来执行任意代码。(CVE-2012-0464)

解决方案

升级到 Solaris 11/11 SRU 8.5。

另见

http://www.nessus.org/u?4a913f44

http://www.nessus.org/u?1876e5a2

插件详情

严重性: High

ID: 80606

文件名: solaris11_firefox_20120626.nasl

版本: 1.4

类型: local

发布时间: 2015/1/19

最近更新时间: 2021/1/14

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 9.3

矢量: AV:N/AC:M/Au:N/C:C/I:C/A:C

漏洞信息

CPE: cpe:/o:oracle:solaris:11.0, p-cpe:/a:oracle:solaris:firefox

必需的 KB 项: Host/local_checks_enabled, Host/Solaris11/release, Host/Solaris11/pkg-list

补丁发布日期: 2012/6/26

参考资料信息

CVE: CVE-2012-0451, CVE-2012-0455, CVE-2012-0456, CVE-2012-0457, CVE-2012-0458, CVE-2012-0459, CVE-2012-0460, CVE-2012-0461, CVE-2012-0462, CVE-2012-0464