PHP 5.5.x < 5.5.20“process_nested_data”RCE

high Nessus 插件 ID 80331
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受到远程代码执行漏洞影响的 PHP 版本。

描述

根据其标题栏,远程主机上安装的 PHP 5.5.x 版本低于 5.5.20。因此,它受到“ext/standard/var_unserializer.re”的“process_nested_data”函数中存在释放后使用错误的影响,产生此错误的原因是对某一对象的已序列化属性内的重复密钥的处理不当。通过使用特别构建的对“unserialize”方法的调用,远程攻击者可利用此缺陷在系统上执行任意代码。

请注意 Nessus 并不试图利用此问题,而只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.5.20 或更新版。

另见

http://php.net/ChangeLog-5.php#5.5.20

https://bugs.php.net/bug.php?id=68594

http://www.nessus.org/u?88c4ed71

插件详情

严重性: High

ID: 80331

文件名: php_5_5_20.nasl

版本: 1.11

类型: remote

系列: CGI abuses

发布时间: 2015/1/2

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

VPR

风险因素: Medium

分数: 6.6

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2014/12/18

漏洞发布日期: 2014/12/18

参考资料信息

CVE: CVE-2014-8142

BID: 71791