Ubuntu 12.04 LTS:linux-lts-trusty 漏洞 (USN-2419-1)

medium Nessus 插件 ID 79434

简介

远程 Ubuntu 主机缺少一个或多个与安全有关的修补程序。

描述

已发现 Linux 内核的 KVM(内核虚拟机)子系统处理 Intel 处理器中的 VM 进入之内的 CR4 控制寄存器的方法中存在缺陷。本地主机 OS 用户可通过利用 /dev/kvm 访问来利用这一点造成拒绝服务(终止任意进程或系统中断)。(CVE-2014-3690)

Don Bailey 在 Linux 内核使用的 LZO 解压缩算法中发现一个缺陷。攻击者可利用此缺陷造成拒绝服务(内存损坏或 OOPS)。(CVE-2014-4608)

Andy Lutomirski 发现与 chroot 目录配合使用时,Linux 内核处理 pivot_root 的方法中存在缺陷。本地用户可利用此缺陷造成拒绝服务(挂载树循环)。
(CVE-2014-7970)

Andy Lutomirski 发现将文件系统重新挂载为只读时,Linux 内核未检查 CAP_SYS_ADMIN。本地用户可利用此缺陷造成拒绝服务(失去可写性)。(CVE-2014-7975)。

解决方案

更新受影响的 linux-image-3.13.0-40-generic 和/或 linux-image-3.13.0-40-generic-lpae 程序包。

另见

https://usn.ubuntu.com/2419-1/

插件详情

严重性: Medium

ID: 79434

文件名: ubuntu_USN-2419-1.nasl

版本: 1.13

类型: local

代理: unix

发布时间: 2014/11/25

最近更新时间: 2021/1/19

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:ND/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.5

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

漏洞信息

CPE: p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13-generic-lpae, cpe:/o:canonical:ubuntu_linux:12.04:-:lts

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2014/11/24

漏洞发布日期: 2014/7/3

参考资料信息

CVE: CVE-2014-3690, CVE-2014-4608, CVE-2014-7970, CVE-2014-7975

BID: 68214, 70314, 70319, 70691

USN: 2419-1