PHP 5.6.x < 5.6.3“donote”DoS

medium Nessus 插件 ID 79248
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受到拒绝服务漏洞影响的 PHP 版本。

描述

根据其标题栏,远程主机上安装的 PHP 5.6.x 版本低于 5.6.3。因此,它受到“ext/fileinfo/libmagic/readelf.c”文件的“donote”函数中的越界读取错误的影响,此错误可导致应用程序崩溃。

请注意,Nessus 并不试图利用这些问题,而只依赖于应用程序自我报告的版本号。

解决方案

升级至 PHP 版本 5.6.3 或更新版。

另见

http://php.net/ChangeLog-5.php#5.6.3

https://bugs.php.net/bug.php?id=68283

http://www.nessus.org/u?6f0615b4

插件详情

严重性: Medium

ID: 79248

文件名: php_5_6_3.nasl

版本: 1.3

类型: remote

系列: CGI abuses

发布时间: 2014/11/14

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2014-3710

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No known exploits are available

补丁发布日期: 2014/11/13

漏洞发布日期: 2014/11/13

参考资料信息

CVE: CVE-2014-3710

BID: 70807