Flash Player <= 15.0.0.189 的多种漏洞 (APSB14-24)

critical Nessus 插件 ID 79140

简介

远程 Windows 主机包含受多种漏洞影响的浏览器插件。

描述

根据其版本,远程 Windows 主机上安装的 Adobe Flash Player 版本为 15.0.0.189 或低于此版本。
因此,它受到以下漏洞的影响:

- 存在多个内存损坏漏洞,使攻击者能够执行任意代码。(CVE-2014-0576、CVE-2014-0581、CVE-2014-8440、CVE-2014-8441)

- 存在多种释放后使用漏洞,可导致任意代码执行。(CVE-2014-0573、CVE-2014-0588、CVE-2014-8438、CVE-2014-0574)

- 存在多种类型混淆漏洞,可导致任意代码执行。(CVE-2014-0577、CVE-2014-0584、CVE-2014-0585、CVE-2014-0586、CVE-2014-0590)

- 存在多种基于堆的缓冲区溢出漏洞,攻击者可利用这些漏洞执行任意代码或提升其权限。(CVE-2014-0583、CVE-2014-0582、CVE-2014-0589)

- 存在权限问题,可允许远程攻击者获得提升的权限。(CVE-2014-8442)

- 存在一个信息泄露漏洞,攻击者可利用此漏洞泄露秘密的会话标记。(CVE-2014-8437)

解决方案

升级到 Adobe Flash Player 15.0.0.223 或更高版本。

或者,Adobe 还为那些无法升级到 15.x 的安装程序提供了 13.0.0.252 版本。

另见

https://helpx.adobe.com/security/products/flash-player/apsb14-24.html

http://www.nessus.org/u?0cb17c10

插件详情

严重性: Critical

ID: 79140

文件名: flash_player_apsb14-24.nasl

版本: 1.15

类型: local

代理: windows

系列: Windows

发布时间: 2014/11/12

最近更新时间: 2022/4/11

配置: 启用彻底检查

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Critical

分数: 9.5

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 8.7

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:H/RL:OF/RC:C

CVSS 分数来源: CVE-2014-8441

漏洞信息

CPE: cpe:/a:adobe:flash_player

必需的 KB 项: SMB/Flash_Player/installed

可利用: true

易利用性: Exploits are available

补丁发布日期: 2014/11/11

漏洞发布日期: 2014/11/11

可利用的方式

Metasploit (Adobe Flash Player UncompressViaZlibVariant Uninitialized Memory)

参考资料信息

CVE: CVE-2014-0573, CVE-2014-0574, CVE-2014-0576, CVE-2014-0577, CVE-2014-0581, CVE-2014-0582, CVE-2014-0583, CVE-2014-0584, CVE-2014-0585, CVE-2014-0586, CVE-2014-0588, CVE-2014-0589, CVE-2014-0590, CVE-2014-8437, CVE-2014-8438, CVE-2014-8440, CVE-2014-8441, CVE-2014-8442

BID: 71033, 71035, 71036, 71037, 71038, 71039, 71040, 71041, 71042, 71043, 71044, 71045, 71046, 71047, 71048, 71049, 71050, 71051