Oracle Linux 5 / 6:firefox (ELSA-2014-0448)

critical Nessus 插件 ID 73794

简介

远程 Oracle Linux 主机缺少安全更新。

描述

来自 Red Hat 安全公告 2014:0448:

更新后的 firefox 程序包修复了多个安全问题,现在可用于 Red Hat Enterprise Linux 5 和 6。

Red Hat 安全响应团队已将此更新评级为具有严重安全影响。可从“参考”部分中的 CVE 链接获取针对每个漏洞的通用漏洞评分系统 (CVSS) 基本分数,其给出了详细的严重性等级。

Mozilla Firefox 是一款开源 Web 浏览器。

在对畸形 Web 内容的处理中发现多个缺陷。包含恶意内容的网页可导致 Firefox 崩溃,或者可能以运行 Firefox 的用户的权限执行任意代码。(CVE-2014-1518、CVE-2014-1524、CVE-2014-1529、CVE-2014-1531)

特定情况下,在 Firefox 解析主机的方式中发现一个释放后使用缺陷。攻击者可利用此缺陷使 Firefox 崩溃,或可能以运行 Firefox 的用户的权限执行任意代码。(CVE-2014-1532)

在 Firefox 解码 JPEG 图像的方式中,发现越界读取缺陷。加载包含特别构建的 JPEG 图像的网页可造成 Firefox 崩溃。(CVE-2014-1523)

在 Firefox 通过历史记录处理浏览器导航的方式中发现一个缺陷。攻击者可能利用此缺陷,在加载来自完全不同网页的内容时,导致浏览器的地址栏显示网页名称,这可允许跨站脚本 (XSS) 攻击。(CVE-2014-1530)

Red Hat 在此感谢 Mozilla 项目报告这些问题。上游感谢这些问题的原始报告者 Bobby Holley、Carsten Book、Christoph Diehl、Gary Kwong、Jan de Mooij、Jesse Ruderman、Nathan Froyd、Christian Holler、Abhishek Arya、Mariusz Mlynski、moz_bug_r_a4、Nils、Tyson Smith 和 Jesse Schwartzentrube。

有关这些缺陷的技术详细信息,请参阅 Firefox 24.5.0 ESR 的 Mozilla 安全公告。在本勘误表的“参考”部分可以找到 Mozilla 公告的链接。

所有 Firefox 用户应升级此更新后的程序包,其中包含已修正了这些问题的 Firefox 24.5.0 ESR。
安装更新后,必须重新启动 Firefox 才能使更改生效。

解决方案

更新受影响的 firefox 程序包。

另见

https://oss.oracle.com/pipermail/el-errata/2014-April/004092.html

https://oss.oracle.com/pipermail/el-errata/2014-April/004095.html

插件详情

严重性: Critical

ID: 73794

文件名: oraclelinux_ELSA-2014-0448.nasl

版本: 1.24

类型: local

代理: unix

发布时间: 2014/5/1

最近更新时间: 2021/1/14

支持的传感器: Frictionless Assessment Agent, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 9.3

时间分数: 6.9

矢量: AV:N/AC:M/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:oracle:linux:firefox, cpe:/o:oracle:linux:5, cpe:/o:oracle:linux:6

必需的 KB 项: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2014/5/1

漏洞发布日期: 2014/4/30

参考资料信息

CVE: CVE-2014-1518, CVE-2014-1523, CVE-2014-1524, CVE-2014-1529, CVE-2014-1530, CVE-2014-1531, CVE-2014-1532

BID: 67123, 67129, 67130, 67131, 67134, 67135, 67137

RHSA: 2014:0448