PHP 5.3.x < 5.3.28 多种 OpenSSL 漏洞

high Nessus 插件 ID 71426
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器采用的 PHP 版本可能受到多种漏洞的影响。

描述

根据其标题,安装在远程主机上的 PHP 版本是 5.3.x,比 5.3.28 更早。因此,它可能会受到以下漏洞的影响:

- 在处理主机名含有空字节的证书时,PHP OpenSSL 扩展的主机名身份检查存在错误。攻击者可能利用此缺陷执行中间人攻击,欺骗 SSL 服务器。请注意,要利用此问题,攻击者需要获取精心构建的证书,该证书由客户端信任的颁发机构签署。(CVE-2013-4073)

- 在 PHP OpenSSL 扩展的 openssl_x509_parse() 函数解析 X.509 证书时,存在内存破坏错误。远程攻击者可能利用该漏洞通过上述函数向 PHP 应用程序提供恶意的、自己签署的证书或由信任的颁发机构签署的证书。这可能引起应用程序崩溃或可能导致攻击者使用运行 PHP 解释器的用户的权限来执行任意代码。(CVE-2013-6420)

请注意,此插件未尝试利用这些漏洞,而是依赖 PHP 自我报告的版本号。

解决方案

升级至 PHP 版本 5.3.28 或更新版。

另见

https://seclists.org/fulldisclosure/2013/Dec/96

https://bugzilla.redhat.com/show_bug.cgi?id=1036830

http://www.nessus.org/u?b6ec9ef9

http://www.php.net/ChangeLog-5.php#5.3.28

插件详情

严重性: High

ID: 71426

文件名: php_5_3_28.nasl

版本: 1.17

类型: remote

系列: CGI abuses

发布时间: 2013/12/14

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

CVSS 分数来源: CVE-2013-6420

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.3

时间分数: 6.6

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

可利用: true

易利用性: No exploit is required

补丁发布日期: 2013/12/12

漏洞发布日期: 2013/6/27

参考资料信息

CVE: CVE-2013-4073, CVE-2013-4248, CVE-2013-6420

BID: 60843, 61776, 64225

EDB-ID: 30395