PHP 5.3.x < 5.3.27 多个漏洞

medium Nessus 插件 ID 67259

简介

远程 Web 服务器采用的 PHP 版本可能受到多种漏洞的影响。

描述

根据其标题栏,远程主机上安装的 PHP 5.3.x 版本低于 5.3.27。因此,它可能会受到以下漏洞的影响:

-“_pdo_pgsql_error”函数中存在缓冲区溢出错误。(错误 #64949)

- 在文件“ext/xml/xml.c”中多个函数存在堆损坏错误。(CVE-2013-4113/错误 #65236)

请注意,此插件未尝试利用这些漏洞,而是依赖 PHP 自我报告的版本号。

解决方案

请安装供应商修补程序或者升级到 PHP 版本 5.3.27 或更高版本。

另见

https://bugs.php.net/bug.php?id=64949

https://bugs.php.net/bug.php?id=65236

http://www.php.net/ChangeLog-5.php#5.3.27

插件详情

严重性: Medium

ID: 67259

文件名: php_5_3_27.nasl

版本: 1.20

类型: remote

系列: CGI abuses

发布时间: 2013/7/12

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2013-4113

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2013/7/11

漏洞发布日期: 2013/7/4

参考资料信息

CVE: CVE-2013-4113

BID: 61128