MySQL 5.5 < 5.5.30 yaSSL 缓冲区溢出

high Nessus 插件 ID 65734
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程数据库服务器受到缓冲区溢出漏洞的影响。

描述

远程主机上安装的 MySQL 5.5 版本低于 5.5.30,因此受到与“yaSSL”相关的缓冲区溢出的影响。
此错误可能允许任意代码执行。

解决方案

升级到 MySQL 版本 5.5.30 或更高版本。

另见

https://www.zerodayinitiative.com/advisories/ZDI-13-251/

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-30.html

https://blogs.oracle.com/sunsecurity/cve-2012-0553-buffer-overflow-vulnerability-in-yassl

http://www.nessus.org/u?c79e27db

插件详情

严重性: High

ID: 65734

文件名: mysql_5_5_30.nasl

版本: 1.7

类型: remote

系列: Databases

发布时间: 2013/3/29

最近更新时间: 2019/11/27

依存关系: mysql_version.nasl, mysql_login.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2013-1492

VPR

风险因素: Medium

分数: 5.8

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:oracle:mysql

必需的 KB 项: Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2013/2/5

漏洞发布日期: 2013/3/19

参考资料信息

CVE: CVE-2013-1492

BID: 58595