Apache 2.2.x < 2.2.24 多种 XSS 漏洞

medium Nessus 插件 ID 64912
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多种跨站脚本漏洞的影响。

描述

根据其标题,远程主机上运行的 Apache 2.2.x 版本低于 2.2.24。因此,它可能会受到以下跨站脚本漏洞的影响:

- 存在与 mod_info、mod_status、mod_imagemap、mod_ldap 和 mod_proxy_ftp 模块以及未转义的主机名和 URI 有关的错误,可允许跨站脚本攻击。(CVE-2012-3499)

- 存在与 mod_proxy_balancer 模块的管理器接口有关的错误,可造成跨站脚本攻击。(CVE-2012-4558)

请注意,Nessus 并未对这些问题进行实际测试,而是依赖服务器标题栏中的版本。

解决方案

升级至 Apache 2.2.24 或更新版本。此为,还需确保没有使用受影响的模块。

另见

https://archive.apache.org/dist/httpd/CHANGES_2.2.24

http://httpd.apache.org/security/vulnerabilities_22.html

插件详情

严重性: Medium

ID: 64912

文件名: apache_2_2_24.nasl

版本: 1.19

类型: remote

系列: Web Servers

发布时间: 2013/2/27

最近更新时间: 2018/6/29

依存关系: apache_http_version.nasl

风险信息

VPR

风险因素: Low

分数: 3

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.3

时间分数: 4.6

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2013/2/26

漏洞发布日期: 2013/2/18

参考资料信息

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990