PostgreSQL 8.3 < 8.3.19 / 8.4 < 8.4.12 / 9.0 < 9.0.8 / 9.1 < 9.1.4 多种漏洞

high Nessus 插件 ID 63353

简介

远程数据库服务器受到多种漏洞的影响。

描述

远程主机上安装的 PostgreSQL 版本为低于 8.3.19 的 8.3.x、低于 8.4.12 的 8.4.x、低于 9.0.8 的 9.0.x,或低于 9.1.4 的 9.1.x。因此,它可能受到多种漏洞的影响:

- 如果使用了 DES 加密,包含传递到 pgcrypto 中 crypt() 函数的 0x80 字节的密码不会被正确截断。(CVE-2012-2143)

- 过程调用处理程序的 SECURITY_DEFINER 和 SET 属性不会被忽略并可被用于导致服务器崩溃。(CVE-2012-2655)

解决方案

升级到 PostgreSQL 8.3.19 / 8.4.12 / 9.0.8 / 9.1.4 或更高版本。

另见

https://www.postgresql.org/about/news/1398/

https://www.postgresql.org/docs/8.3/release-8-3-19.html

https://www.postgresql.org/docs/8.4/release-8-4-12.html

https://www.postgresql.org/docs/9.0/release-9-0-8.html

https://www.postgresql.org/docs/9.1/release-9-1-4.html

插件详情

严重性: High

ID: 63353

文件名: postgresql_20120604.nasl

版本: 1.14

类型: local

系列: Databases

发布时间: 2012/12/28

最近更新时间: 2022/4/11

风险信息

CVSS 分数来源: CVE-2012-2143

VPR

风险因素: Medium

分数: 4

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.7

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:postgresql:postgresql

易利用性: No known exploits are available

补丁发布日期: 2012/5/30

漏洞发布日期: 2012/5/31

参考资料信息

CVE: CVE-2012-2143, CVE-2012-2655

BID: 53729, 53812