PostgreSQL 7.4 < 7.4.29 / 8.0 < 8.0.25 / 8.1 < 8.1.21 / 8.2 < 8.2.17 / 8.3 < 8.3.11 / 8.4 < 8.4.4 多种漏洞

high Nessus 插件 ID 63349
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程数据库服务器受到多种漏洞的影响。

描述

远程主机上安装的 PostgreSQL 版本为低于 7.4.29 的 7.4、低于 8.0.25 的 8.0、低于 8.1.21 的 8.1、低于 8.2.17 的 8.2、低于 8.3.11 的 8.3,或低于 8.4.4 的 8.4。因此,它可能受到多种漏洞的影响:

- 如果安装并启用了 PL/Perl,Safe.pm 和 PL/Perl 中的一个漏洞可允许经认证的用户在数据库服务器上运行任意 Perl 代码。
(CVE-2010-1169)

- 如果安装并启用了 PL/Tcl,pltcl_modules 表上的不安全权限可允许经认证的用户在数据库服务器上运行任意 Tcl 代码。(CVE-2010-1170)

- 非特权数据库用户可删除由超级用户通过 ALTER USER 对该用户的帐户应用的仅供超级用户使用的设置,从而绕过应强制实施的设置。(CVE-2010-1975)

解决方案

升级到 PostgreSQL 7.4.29 / 8.0.25 / 8.1.21 / 8.2.17 / 8.3.11 / 8.4.4 或更高版本。

另见

https://www.postgresql.org/about/news/1203/

https://www.postgresql.org/docs/7.4/release-7-4-29.html

https://www.postgresql.org/docs/8.0/release-8-0-25.html

https://www.postgresql.org/docs/8.1/release-8-1-21.html

https://www.postgresql.org/docs/8.2/release-8-2-17.html

http://www.postgresql.org/docs/8.3/static/release-8-3-11.html

http://www.postgresql.org/docs/8.4/static/release-8-4-4.html

插件详情

严重性: High

ID: 63349

文件名: postgresql_20100517.nasl

版本: 1.9

类型: local

系列: Databases

发布时间: 2012/12/28

最近更新时间: 2018/11/15

依存关系: postgresql_version.nbin

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 8.5

时间分数: 6.3

矢量: AV:N/AC:M/Au:S/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.7

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:postgresql:postgresql

易利用性: No known exploits are available

补丁发布日期: 2010/5/14

漏洞发布日期: 2010/5/14

参考资料信息

CVE: CVE-2010-1169, CVE-2010-1170, CVE-2010-1975

BID: 40215, 40304