PHP 5.3.x < 5.3.15 多个漏洞

critical Nessus 插件 ID 60085
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,远程主机上安装的 PHP 5.3.x 版低于 5.3.15,因此可能受到以下漏洞的影响:

- 文件“main/streams/streams.c”中的函数“_php_stream_scandir”存在不明溢出漏洞。(CVE-2012-2688)

- 存在一个不明错误,允许绕过“open_basedir”限制。
(CVE-2012-3365)

解决方案

升级至 PHP 5.3.15 或更高版本。

另见

http://www.php.net/ChangeLog-5.php#5.3.15

插件详情

严重性: Critical

ID: 60085

文件名: php_5_3_15.nasl

版本: 1.10

类型: remote

系列: CGI abuses

发布时间: 2012/7/20

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.4

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2012/7/19

漏洞发布日期: 2012/7/19

参考资料信息

CVE: CVE-2012-2688, CVE-2012-3365

BID: 54612, 54638