PHP < 5.3.9 多种漏洞

high Nessus 插件 ID 57537
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器使用的 PHP 版本受到多种缺陷的影响。

描述

根据其标题,远程主机上安装的 PHP 版本早于 5.3.9。因此,它可能会受到以下安全问题的影响:

- PHP 5.3.7 和 5.3.8 中的“is_a()”函数触发对“__autoload()”的调用。(CVE-2011-3379)

- 可以通过发送多种特别构建的包含可在计算哈希表中用于存储的哈希值时导致哈希冲突的参数值的请求来造成拒绝服务情况。(CVE-2011-4885)
- exif.c 中的 exif_process_IFD_TAG 函数中存在一个整数溢出,可允许远程攻击者读取任意内存位置或造成拒绝服务情况。此漏洞仅影响 32 位平台上的 PHP 5.4.0beta2。(CVE-2011-4566)

- 通过 xsltSetSecurityPrefs() 对 libxslt 的调用未受到限制,这可允许攻击者创建或覆盖文件,从而导致任意代码执行。(CVE-2012-0057)

- “tidy_diagnose”函数中存在一个错误,可允许攻击者造成应用程序取消引用空指针。这样会导致应用程序崩溃。(CVE-2012-0781)

- “PDORow”实现包含一个错误,可造成应用程序在与会话功能交互时崩溃。(CVE-2012-0788)

- 时区处理中存在一个错误,导致对“strtotime”函数的反复调用可允许通过内存消耗进行拒绝服务攻击。
(CVE-2012-0789)

解决方案

升级至 PHP 版本 5.3.9 或更新版。

另见

https://www.tenable.com/security/research/tra-2012-01

http://xhe.myxwiki.org/xwiki/bin/view/XSLT/Application_PHP5

http://www.php.net/archive/2012.php#id2012-01-11-1

https://seclists.org/bugtraq/2012/Jan/91

https://bugs.php.net/bug.php?id=55475

https://bugs.php.net/bug.php?id=55776

https://bugs.php.net/bug.php?id=53502

http://www.php.net/ChangeLog-5.php#5.3.9

插件详情

严重性: High

ID: 57537

文件名: php_5_3_9.nasl

版本: 1.24

类型: remote

系列: CGI abuses

发布时间: 2012/1/13

最近更新时间: 2021/1/19

依存关系: php_version.nasl

风险信息

VPR

风险因素: Medium

分数: 5.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:H/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2012/1/11

漏洞发布日期: 2011/9/23

可利用的方式

Core Impact

参考资料信息

CVE: CVE-2011-3379, CVE-2011-4566, CVE-2011-4885, CVE-2012-0057, CVE-2012-0781, CVE-2012-0788, CVE-2012-0789

BID: 49754, 50907, 51193, 51806, 51952, 51992, 52043