USN-1244-1:linux-ti-omap4 漏洞

high Nessus 插件 ID 56643

简介

远程 Ubuntu 主机缺少一个或多个与安全有关的修补程序。

描述

Dan Rosenberg 发现 Linux 内核 X.25 实现未正确解析设施。远程攻击者可利用此漏洞造成内核崩溃,从而导致拒绝服务。(CVE-2010-3873)

Andrea Righi 在 KSM 内存合并支持中发现争用条件。如果使用 KSM,本地攻击者可利用此缺陷造成系统崩溃,从而导致拒绝服务。(CVE-2011-2183)

Vasily Averin 发现 NFS 锁定管理器 (NLM) 未正确处理解锁请求。本地攻击者可利用此缺陷造成拒绝服务。(CVE-2011-2491)

Vasiliy Kulikov 发现 taskstats 未强制实施访问限制。本地攻击者可利用此缺陷来读取特定信息,从而导致失去隐私。(CVE-2011-2494)

Vasiliy Kulikov 发现 /proc/PID/io 未强制实施访问限制。本地攻击者可利用此缺陷来读取特定信息,从而导致失去隐私。(CVE-2011-2495)

已发现无线堆栈未正确验证 SSID 的长度。本地攻击者可利用此缺陷造成拒绝服务或获得根权限。(CVE-2011-2517)

已发现 EXT4 文件系统包含多个差一缺陷。本地攻击者可利用此缺陷造成系统崩溃,从而导致拒绝服务。(CVE-2011-2695)

Christian Ohm 发现 perf 命令查找当前目录中的配置文件。如果特权用户受到诱骗,在包含恶意配置文件的目录中运行 perf,则攻击者可运行任意命令并可能获得权限。(CVE-2011-2905)

Vasiliy Kulikov 发现 Comedi 驱动程序未正确清除内存。本地攻击者可利用此缺陷读取内核堆栈内存,从而导致失去隐私。(CVE-2011-2909)

Yogesh Sharma 发现 CIFS 未正确处理没有前缀路径的 UNC。能够访问 CIFS 分区的本地攻击者可以利用此问题使系统崩溃,从而导致拒绝服务。(CVE-2011-3363)

解决方案

更新受影响的程序包。

另见

http://www.ubuntu.com/usn/usn-1244-1/

插件详情

严重性: High

ID: 56643

文件名: ubuntu_USN-1244-1.nasl

版本: Revision: 1.2

类型: local

代理: unix

发布时间: 2011/10/26

最近更新时间: 2016/12/1

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 7.8

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux

必需的 KB 项: Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

补丁发布日期: 2011/10/25

参考资料信息

CVE: CVE-2010-3873, CVE-2011-2183, CVE-2011-2491, CVE-2011-2494, CVE-2011-2495, CVE-2011-2517, CVE-2011-2695, CVE-2011-2905, CVE-2011-2909, CVE-2011-3363

USN: 1244-1