PHP 5.3 < 5.3.7 多种漏洞

critical Nessus 插件 ID 55925

简介

远程 Web 服务器使用受多种漏洞影响的 PHP 版本。

描述

根据其标题,远程主机上运行的 PHP 5.3.x 版本低于 5.3.7。因此,它受到以下漏洞的影响:

- substr_replace() 的释放后使用漏洞。
(CVE-2011-1148)

- socket_connect() 中基于堆栈的缓冲区溢出。
(CVE-2011-1938)

- ZipArchive::addGlob() 中的代码执行漏洞。
(CVE-2011-1657)

- crypt_blowfish 已更新至 1.2。(CVE-2011-2483)

- 多种空指针取消引用问题。(CVE-2011-3182)

- error_log() 中的不明崩溃。(CVE-2011-3267)

- crypt() 中的缓冲区溢出。(CVE-2011-3268)

- 将 MCRYPT_DEV_URANDOM 作为来源传递至 mcrypt_create_iv() 时,php_win32_get_random_bytes() 函数中存在一个缺陷。远程攻击者可利用此缺陷造成拒绝服务。(OSVDB 126477)

解决方案

请升级到 PHP 5.3.7 或更高版本。

另见

http://securityreason.com/achievement_securityalert/101

http://securityreason.com/exploitalert/10738

https://bugs.php.net/bug.php?id=54238

https://bugs.php.net/bug.php?id=54681

https://bugs.php.net/bug.php?id=54939

http://www.php.net/releases/5_3_7.php

插件详情

严重性: Critical

ID: 55925

文件名: php_5_3_7.nasl

版本: 1.21

类型: remote

系列: CGI abuses

发布时间: 2011/8/22

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6.1

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.8

矢量: AV:N/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS 分数来源: CVE-2011-3268

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2011/8/18

漏洞发布日期: 2011/3/13

参考资料信息

CVE: CVE-2011-1148, CVE-2011-1657, CVE-2011-1938, CVE-2011-2202, CVE-2011-2483, CVE-2011-3182, CVE-2011-3267, CVE-2011-3268

BID: 46843, 47950, 48259, 49241, 49249, 49252

EDB-ID: 17318, 17486