Apache 2.2.x < 2.2.14 Multiple Vulnerabilities

high Nessus 插件 ID 42052
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

The remote web server is affected by multiple vulnerabilities.

描述

According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.14. It is, therefore, potentially affected by multiple vulnerabilities :

- Faulty error handling in the Solaris pollset support could lead to a denial of service. (CVE-2009-2699)

- The 'mod_proxy_ftp' module allows remote attackers to bypass intended access restrictions. (CVE-2009-3095)

- The 'ap_proxy_ftp_handler' function in 'modules/proxy/proxy_ftp.c' in the 'mod_proxy_ftp' module allows remote FTP servers to cause a denial of service. (CVE-2009-3094)

Note that the remote web server may not actually be affected by these vulnerabilities as Nessus did not try to determine whether the affected modules are in use or check for the issues themselves.

解决方案

Upgrade to Apache version 2.2.14 or later. Alternatively, ensure that the affected modules are not in use.

另见

http://www.securityfocus.com/advisories/17947

http://www.securityfocus.com/advisories/17959

http://www.nessus.org/u?e470f137

https://bz.apache.org/bugzilla/show_bug.cgi?id=47645

http://www.nessus.org/u?c34c4eda

插件详情

严重性: High

ID: 42052

文件名: apache_2_2_14.nasl

版本: 1.32

类型: remote

系列: Web Servers

发布时间: 2009/10/7

最近更新时间: 2018/11/15

依存关系: apache_http_version.nasl

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.3

时间分数: 6.4

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2009/10/5

漏洞发布日期: 2009/10/5

参考资料信息

CVE: CVE-2009-2699, CVE-2009-3094, CVE-2009-3095

BID: 36596, 36254, 36260

CWE: 119, 264

Secunia: 36549