Tomcat Sample App cal2.jsp 'time' Parameter XSS

medium Nessus 插件 ID 35806

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

The remote web server contains a JSP application that is affected by a cross-site scripting vulnerability.

描述

The remote web server includes an example JSP application, 'cal2.jsp', that fails to sanitize user-supplied input before using it to generate dynamic content. An unauthenticated, remote attacker can exploit this issue to inject arbitrary HTML or script code into a user's browser to be executed within the security context of the affected site.

解决方案

Upgrade to Apache Tomcat version 4.1.40 / 5.5.28 / 6.0.20.
Alternatively, apply the appropriate patch referenced in the vendor advisory or undeploy the Tomcat examples web application.

另见

https://www.securityfocus.com/archive/1/501538/30/0/threaded

http://tomcat.apache.org/security-6.html

http://tomcat.apache.org/security-5.html

http://tomcat.apache.org/security-4.html

插件详情

严重性: Medium

ID: 35806

文件名: tomcat_sample_cal2_xss2.nasl

版本: 1.22

类型: remote

发布时间: 2009/3/9

最近更新时间: 2021/1/19

依存关系: tomcat_error_version.nasl

风险信息

VPR

风险因素: Low

分数: 2.2

CVSS v2

风险因素: Medium

基本分数: 4.3

矢量: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

风险因素: Medium

基本分数: 5.3

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

漏洞信息

CPE: cpe:/a:apache:tomcat

必需的 KB 项: installed_sw/Apache Tomcat

排除的 KB 项: Settings/disable_cgi_scanning

补丁发布日期: 2009/3/6

参考资料信息

CVE: CVE-2009-0781

CWE: 79