PHP < 4.4.9 多种漏洞

high Nessus 插件 ID 33849

简介

远程 Web 服务器使用的 PHP 版本受到多种问题的影响。

描述

根据其标题,远程主机上安装的 PHP 版本早于 4.4.9。此类版本可能会受到多个安全问题的影响:

- 由 7.7 版修复的捆绑式 PCRE 中不明的问题。

-“ext/gd/gd.c”的“imageloadfont()”函数中存在缓冲区溢出,当提供特别构建的字体时,可触发此漏洞。(CVE-2008-3658)

- 内部“memnstr()”函数中存在缓冲区溢出,可导致信息以“explode()”形式暴露在用户空间。
(CVE-2008-3659)

- 文件名包含两个点时存在拒绝服务漏洞。(CVE-2008-3660)

- curl 扩展中存在“open_basedir”处理问题。

-“.htaccess”中设置的“mbstring.func_overload”变为全局值。(CVE-2009-0754)

请注意,版本声明陈述这将是 PHP 4.4 系列的最后一个版本。

解决方案

升级至 PHP 4.4.9 或更高版本。

另见

https://www.openwall.com/lists/oss-security/2008/08/08/2

http://www.php.net/releases/4_4_9.php

http://www.php.net/ChangeLog-4.php#4.4.9

https://bugs.php.net/bug.php?id=27421

插件详情

严重性: High

ID: 33849

文件名: php_4_4_9.nasl

版本: 1.28

类型: remote

系列: CGI abuses

发布时间: 2008/8/8

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.9

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

参考资料信息

CVE: CVE-2007-4850, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660, CVE-2009-0754

BID: 27413, 30649, 31612, 33542

SECUNIA: 31409

CWE: 20, 119, 134, 264