PHP < 4.4.3 / 5.1.4 多种漏洞

high Nessus 插件 ID 22268

简介

远程 Web 服务器使用的 PHP 版本受到多种缺陷的影响。

描述

根据其标题,远程主机上安装的 PHP 版本低于 4.4.3 / 5.1.4。此类版本可能会受到多个问题的影响,包括缓冲区溢出、堆损坏以及变量可免于对“unset()”的调用的缺陷。

解决方案

升级到 PHP 4.4.3 / 5.1.4 或更新版本。

另见

http://www.nessus.org/u?a7553cd8

http://www.nessus.org/u?ccaf872d

https://www.securityfocus.com/archive/1/archive/1/442437/100/0/threaded

http://us3.php.net/releases/4_4_3.php

http://us3.php.net/releases/5_1_3.php

http://www.php.net/release_5_1_4.php

插件详情

严重性: High

ID: 22268

文件名: php_4_4_3.nasl

版本: 1.26

类型: remote

系列: CGI abuses

发布时间: 2006/8/25

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 6

CVSS v2

风险因素: High

基本分数: 9.3

时间分数: 7.3

矢量: AV:N/AC:M/Au:N/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP

易利用性: No exploit is required

补丁发布日期: 2006/8/3

漏洞发布日期: 2006/3/28

参考资料信息

CVE: CVE-2006-0996, CVE-2006-1490, CVE-2006-1494, CVE-2006-1608, CVE-2006-1990, CVE-2006-1991, CVE-2006-2563, CVE-2006-2660, CVE-2006-3011, CVE-2006-3016, CVE-2006-3017, CVE-2006-3018, CVE-2006-4433

BID: 17296, 17362, 17439, 17843, 18116, 18645, 49634

CWE: 79