网络块设备 (NBD) 服务器请求处理远程溢出

high Nessus 插件 ID 20341

简介

远程服务受到一个缓冲区溢出漏洞的影响。

描述

远程主机上安装的网络块设备 (NBD) 服务器版本未正确检查读取请求的大小,便填充动态分配的缓冲区。攻击者可使用特别构建的读取请求覆盖此缓冲区,这会导致受影响的服务器崩溃或允许执行任意代码。

解决方案

升级至 NBD 2.8.3 或更高版本。

另见

http://www.nessus.org/u?d8968f54

http://www.nessus.org/u?7ef06d96

插件详情

严重性: High

ID: 20341

文件名: nbd_bufsize_overflow.nasl

版本: 1.18

类型: remote

发布时间: 2005/12/24

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Medium

分数: 5.5

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

漏洞信息

易利用性: No known exploits are available

漏洞发布日期: 2005/12/21

参考资料信息

CVE: CVE-2005-3534

BID: 16029