GLSA-202210-14 : Gitea:多个漏洞

critical Nessus 插件 ID 166729

语言:

描述

远程主机受到 GLSA-202210-14 中所述漏洞的影响(Gitea:多个漏洞)

- 跨站脚本 (XSS) - 存储在 1.16.9 之前的 GitHub 存储库 go-gitea/gitea 中。(CVE-2022-1928)

- 攻击者可构建需要 ParseAcceptLanguage 花费大量时间来解析的 Accept-Language 标头,从而造成拒绝服务。(CVE-2022-32149)

- 在 1.16.9之前的 Gitea 中,用户可以向项目添加现有问题。由于访问控制不当,攻击者可以将任何问题分配给 Gitea 中的任何项目(没有用于提取问题的权限检查)。因此,攻击者将获得访问隐私问题标题的权限。
(CVE-2022-38183)

- 1.17.3 之前的 Gitea 不会审查和转义 git 后端中的引用。对 git 命令的参数的处理不当。(CVE-2022-42968)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

所有 Gitea 用户皆应升级到最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=www-apps/gitea-1.17.3

另见

https://security.gentoo.org/glsa/202210-14

https://bugs.gentoo.org/show_bug.cgi?id=848465

https://bugs.gentoo.org/show_bug.cgi?id=857819

https://bugs.gentoo.org/show_bug.cgi?id=868996

https://bugs.gentoo.org/show_bug.cgi?id=877355

插件详情

严重性: Critical

ID: 166729

文件名: gentoo_GLSA-202210-14.nasl

版本: 1.4

类型: local

发布时间: 2022/10/31

最近更新时间: 2022/12/15

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Low

基本分数: 3.5

时间分数: 2.6

矢量: AV:N/AC:M/Au:S/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-1928

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

CVSS 分数来源: CVE-2022-42968

漏洞信息

CPE: p-cpe:/a:gentoo:linux:gitea, cpe:/o:gentoo:linux

必需的 KB 项: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

易利用性: No known exploits are available

补丁发布日期: 2022/10/31

漏洞发布日期: 2022/5/29

参考资料信息

CVE: CVE-2022-1928, CVE-2022-32149, CVE-2022-38183, CVE-2022-42968

IAVB: 2022-B-0046-S