GLSA-202210-15 : GDAL:堆缓冲区溢出

medium Nessus 插件 ID 166727

语言:

描述

远程主机受到 GLSA-202210-15 中所述漏洞的影响(GDAL:堆缓冲区溢出)

- 在 GDAL 3.3.0 至 3.4.0 中,PCIDSK: : CPCIDSKFile: : ReadFromFile 中存在基于堆的缓冲区溢出漏洞(从 PCIDSK: : CPCIDSKSegment: : ReadFromFile 和 PCIDSK: : CPCIDSKBinarySegment: : CPCIDSKBinarySegment 调用)。
(CVE-2021-45943)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

所有 GDAL 用户皆应升级到最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=sci-libs/gdal-3.4.1

另见

https://security.gentoo.org/glsa/202210-15

https://bugs.gentoo.org/show_bug.cgi?id=830370

插件详情

严重性: Medium

ID: 166727

文件名: gentoo_GLSA-202210-15.nasl

版本: 1.2

类型: local

发布时间: 2022/10/31

最近更新时间: 2022/10/31

风险信息

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

时间矢量: CVSS2#E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-45943

CVSS v3

风险因素: Medium

基本分数: 5.5

时间分数: 4.8

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:gdal:*:*:*:*:*:*:*

必需的 KB 项: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

易利用性: No known exploits are available

补丁发布日期: 2022/10/31

漏洞发布日期: 2022/1/1

参考资料信息

CVE: CVE-2021-45943