GitLab < 15.0.5 / 15.1 < 15.1.4 / 15.2 < 15.2.1 不当访问

high Nessus 插件 ID 163831

简介

远程 Web 服务器上运行的源代码控制应用程序受到访问不正确漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 GitLab 实例为低于 15.0.5 的版本、低于 15.1.4 的 15.1 或低于 15.2.1 的 15.2。因此,它受到不当访问漏洞的影响,攻击者可使用其他用户的电子邮件地址作为未经验证的辅助电子邮件地址,从而通过电子邮件邀请获得对私人项目的访问权限。

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级至 GitLab 15.0.5、15.1.4、15.2.1 或更新版本。

另见

http://www.nessus.org/u?83aadce8

插件详情

严重性: High

ID: 163831

文件名: gitlab_cve-2022-2326.nasl

版本: 1.7

类型: combined

代理: unix

系列: CGI abuses

发布时间: 2022/8/4

最近更新时间: 2022/8/31

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 5.2

CVSS v2

风险因素: Medium

基本分数: 6.6

时间分数: 4.9

矢量: AV:N/AC:H/Au:S/C:C/I:C/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-2326

CVSS v3

风险因素: High

基本分数: 8.1

时间分数: 7.1

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:gitlab:gitlab

必需的 KB 项: installed_sw/GitLab

易利用性: No known exploits are available

补丁发布日期: 2022/7/28

漏洞发布日期: 2022/7/28

参考资料信息

CVE: CVE-2022-2326

IAVA: 2022-A-0302-S