GitLab < 15.0.5 / 15.1 < 15.1.4 / 15.2 < 15.2.1 安全绕过

low Nessus 插件 ID 163790

简介

远程 Web 服务器上运行的源代码控制应用程序受到安全绕过漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 GitLab 实例为低于 15.0.5 的版本、低于 15.1.4 的 15.1 或低于 15.2.1 的 15.2。因此,它受到安全绕过漏洞的影响,这是因为如果在阻止添加成员的设置启用之前发送邀请,受邀成员仍可以在群组拥有者启用该设置之后加入项目。未经身份验证的远程攻击者可利用此漏洞来添加成员,或得取对项目的访问权限。

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级至 GitLab 15.0.5、15.1.4、15.2.1 或更新版本。

另见

http://www.nessus.org/u?198ace5a

插件详情

严重性: Low

ID: 163790

文件名: gitlab_cve-2022-2459.nasl

版本: 1.4

类型: combined

代理: unix

系列: CGI abuses

发布时间: 2022/8/3

最近更新时间: 2022/8/30

配置: 启用彻底检查

支持的传感器: Nessus Agent

风险信息

VPR

风险因素: Low

分数: 1.4

CVSS v2

风险因素: Medium

基本分数: 4

时间分数: 3

矢量: AV:N/AC:L/Au:S/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-2459

CVSS v3

风险因素: Low

基本分数: 2.7

时间分数: 2.4

矢量: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:gitlab:gitlab

必需的 KB 项: installed_sw/GitLab

易利用性: No known exploits are available

补丁发布日期: 2022/7/28

漏洞发布日期: 2022/7/28

参考资料信息

CVE: CVE-2022-2459

IAVA: 2022-A-0302-S