Apache 2.4.x < 2.4.52 mod_lua 缓冲区溢出漏洞

critical Nessus 插件 ID 161454

简介

远程 Web 服务器受到缓冲区溢出漏洞的影响。

描述

远程主机上安装的 Apache httpd 版本低于 2.4.52。因此,其在处理多部分内容时会受到与 mod_lua 相关的缺陷影响。- 精心构建的请求正文可导致 mod_lua 多部分解析器(从 Lua 脚本调用的 r: parsebody())中出现缓冲区溢出问题。Apache httpd 团队并未发现利用该漏洞的情况,但攻击者可能会另外构建漏洞。

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级至 Apache 2.4.52 或更高版本。

插件详情

严重性: Critical

ID: 161454

文件名: apache_2_4_52_CVE-2021-44790.nasl

版本: 1.4

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2022/5/24

最近更新时间: 2022/5/26

配置: 启用彻底检查

支持的传感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

风险信息

VPR

风险因素: High

分数: 8.4

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 5.5

矢量: AV:N/AC:L/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-44790

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2021/12/20

漏洞发布日期: 2021/11/18

参考资料信息

CVE: CVE-2021-44790

IAVA: 2021-A-0604-S