PHP 8.1.x < 8.1.3

critical Nessus 插件 ID 158154

简介

远程 Web 服务器上运行的 PHP 版本受到一个漏洞的影响。

描述

远程主机上安装的 PHP 版本低于 8.1.3,因此受到版本 8.1.3 公告中提及的漏洞的影响。

- 在低于 7.4.28 的 PHP 7.4.x 版本、低于 8.0.16 的 PHP 8.0.x 版本以及低于 8.1.3 的 PHP 8.1.x 版本中,当使用具有 FILTER_VALIDATE_FLOAT 过滤条件和最小/最大限制的过滤函数时,如果过滤失败,则有可能触发在释放后使用已分配的内存,进而可能导致系统崩溃,并有可能覆盖其他内存区块和 RCE。此问题影响以下版本:使用设有最小/最大限制的 FILTER_VALIDATE_FLOAT 的代码。
(CVE-2021-21708)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级至 PHP 8.1.3 或更高版本。

另见

http://php.net/ChangeLog-8.php#8.1.3

插件详情

严重性: Critical

ID: 158154

文件名: php_8_1_3.nasl

版本: 1.5

类型: remote

系列: CGI abuses

发布时间: 2022/2/18

最近更新时间: 2022/4/11

配置: 启用彻底检查

风险信息

VPR

风险因素: Critical

分数: 9

CVSS v2

风险因素: Medium

基本分数: 6.8

时间分数: 5

矢量: AV:N/AC:M/Au:N/C:P/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-21708

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:php:php

必需的 KB 项: www/PHP, installed_sw/PHP

易利用性: No known exploits are available

补丁发布日期: 2022/2/17

漏洞发布日期: 2022/2/17

参考资料信息

CVE: CVE-2021-21708