Oracle MySQL Server(2022 年 1 月 CPU)

high Nessus 插件 ID 156907

简介

远程主机受到多个漏洞的影响

描述

远程主机上安装的 MySQL Server 版本受到 2022 年 1 月 CPU 公告中提及的多个漏洞影响。

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:Server: Compiling)。支持的版本中受影响的是 5.7.36 和较早版本以及 8.0.27 和较早版本。利用此漏洞的难度较低,通过多种协议进行网络访问的高权限攻击者可借此破坏 MySQL Server。
成功利用此漏洞进行攻击可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完整 DOS),以及未经授权更新、插入或删除某些 MySQL Server 可访问数据的访问权限。(CVE-2022-21367)

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:Server: Replication)。支持的版本中受影响的是 5.7.36 和较早版本以及 8.0.27 和较早版本。利用此漏洞的难度较低,通过多种协议进行网络访问的高权限攻击者可借此破坏 MySQL Server。
成功攻击此漏洞可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完全 DOS)。(CVE-2022-21344)

- Oracle MySQL 的 MySQL Server 产品中存在漏洞(组件:Server: Parser)。支持的版本中受影响的是 5.7.36 和较早版本以及 8.0.27 和较早版本。利用此漏洞的难度较低,通过多种协议进行网络访问的高权限攻击者可借此破坏 MySQL Server。成功攻击此漏洞可导致在未经授权的情况下造成 MySQL Server 挂起或频繁出现崩溃(完全 DOS)。(CVE-2022-21304)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

请根据 2022 年 1 月 Oracle 关键补丁更新公告应用相应补丁。

另见

https://www.oracle.com/a/tech/docs/cpujan2022cvrf.xml

https://www.oracle.com/security-alerts/cpujan2022.html

插件详情

严重性: High

ID: 156907

文件名: mysql_5_7_37.nasl

版本: 1.3

类型: remote

系列: Databases

发布时间: 2022/1/20

最近更新时间: 2022/5/6

配置: 启用偏执模式

支持的传感器: Frictionless Assessment Agent

风险信息

VPR

风险因素: Medium

分数: 5.1

CVSS v2

风险因素: Medium

基本分数: 5.5

时间分数: 4.1

矢量: AV:N/AC:L/Au:S/C:N/I:P/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2022-21367

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:U/RL:O/RC:C

CVSS 分数来源: CVE-2021-22946

漏洞信息

CPE: cpe:/a:oracle:mysql

必需的 KB 项: Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2022/1/18

漏洞发布日期: 2022/1/18

参考资料信息

CVE: CVE-2021-22946, CVE-2022-21245, CVE-2022-21270, CVE-2022-21303, CVE-2022-21304, CVE-2022-21344, CVE-2022-21367