Ubuntu 18.04 LTS:QtSvg 漏洞 (USN-5241-1)

high Nessus 插件 ID 156880

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 18.04 LTS 主机上安装的程序包受到 USN-5241-1 公告中提及的多个漏洞的影响。

- 在 5.11.3 之前的 Qt 中发现一个问题。格式错误的 SVG 图像会导致 qsvghandler.cpp 中产生段错误。(CVE-2018-19869)

- Qt 5.0.0 版至 5.15.2 版和 6.0.0 版至 6.2.1 版的 Qt SVG 的 QtPrivate: : QCommonArrayOps<QPainterPath: : Element>: : growAppend(调用自 QPainterPath: : addPath 和 QPathClipper: : intersect)中存在越界写入漏洞。(CVE-2021-45930)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

更新受影响的 libqt5svg5、libqt5svg5-dev 和/或 qtsvg5-examples 程序包。

另见

https://ubuntu.com/security/notices/USN-5241-1

插件详情

严重性: High

ID: 156880

文件名: ubuntu_USN-5241-1.nasl

版本: 1.4

类型: local

代理: unix

发布时间: 2022/1/20

最近更新时间: 2022/8/25

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

风险信息

VPR

风险因素: Medium

分数: 6

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.2

矢量: AV:N/AC:M/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS 分数来源: CVE-2021-45930

CVSS v3

风险因素: High

基本分数: 7.1

时间分数: 6.2

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

时间矢量: E:U/RL:O/RC:C

CVSS 分数来源: CVE-2021-3481

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libqt5svg5, p-cpe:/a:canonical:ubuntu_linux:libqt5svg5-dev, p-cpe:/a:canonical:ubuntu_linux:qtsvg5-examples

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2022/1/19

漏洞发布日期: 2018/12/4

参考资料信息

CVE: CVE-2018-19869, CVE-2021-3481, CVE-2021-45930

USN: 5241-1