Apple iOS < 15.1 多个漏洞 (HT212867)

high Nessus 插件 ID 154722

简介

移动设备上运行的 Apple iOS 版本受到多个漏洞影响。

描述

移动设备上运行的 Apple iOS 版本低于 15.1。因此,该应用程序受到多个漏洞的影响,其中包括:

- ICC 配置文件的处理中存在内存损坏问题。已通过改进输入验证解决此问题。此问题已在 iOS 15.1 与 iPadOS 15.1、macOS Monterey 12.0.1、iOS 14.8.1 与 iPadOS 14.8.1、tvOS 15.1、watchOS 8.1、安全更新 2021-007 Catalina、macOS Big Sur 11.6.1 中修复。
处理恶意构建的图像可能会导致任意代码执行。(CVE-2021-30917)

- 已通过改进内存处理解决输入验证问题。此问题已在 iOS 15.1 与 iPadOS 15.1、macOS Monterey 12.0.1、tvOS 15.1、watchOS 8.1、安全更新 2021-007 Catalina、macOS Big Sur 11.6.1 中修复。解压缩恶意构建的存档可能会导致任意代码执行。(CVE-2021-30881)

- 已通过改进的边界检查解决越界写入问题。此问题已在 iOS 14.8.1 与 iPadOS 14.8.1、iOS 15.1 与 iPadOS 15.1 中修复。恶意应用程序可能以内核权限执行任意代码。(CVE-2021-30900)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号。

解决方案

升级到 Apple iOS 版本 15.1 或更高版本

另见

https://support.apple.com/en-us/HT212867

插件详情

严重性: High

ID: 154722

文件名: apple_ios_151_check.nbin

版本: 1.12

类型: local

发布时间: 2021/10/29

最近更新时间: 2022/5/24

风险信息

CVSS 分数来源: CVE-2021-30916

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: High

基本分数: 9.3

时间分数: 7.3

矢量: AV:N/AC:M/Au:N/C:C/I:C/A:C

时间矢量: E:POC/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 7.9

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/o:apple:iphone_os

必需的 KB 项: mdm/dependency/unlocked

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/10/27

漏洞发布日期: 2021/8/24

参考资料信息

CVE: CVE-2021-30875, CVE-2021-30881, CVE-2021-30886, CVE-2021-30887, CVE-2021-30888, CVE-2021-30889, CVE-2021-30890, CVE-2021-30894, CVE-2021-30900, CVE-2021-30902, CVE-2021-30903, CVE-2021-30905, CVE-2021-30906, CVE-2021-30907, CVE-2021-30909, CVE-2021-30910, CVE-2021-30911, CVE-2021-30914, CVE-2021-30915, CVE-2021-30916, CVE-2021-30917, CVE-2021-30919

APPLE-SA: APPLE-SA-2021-10-26-1, HT212867

IAVA: 2021-A-0506-S