Apache 2.4.49 < 2.4.50 多个漏洞

high Nessus 插件 ID 153884
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器受到多个漏洞影响。

描述

远程主机上安装的 Apache httpd 版本为 2.4.49。因此,如公告 2.4.50 所述,该主机受到多个漏洞的影响。

- 对 2.4.49 httpd 进行模糊测试时,在处理 HTTP/2 请求的过程中检测到新的空指针取消引用,外部源可利用此漏洞对服务器造成 DoS。这需要使用特别构建的请求。该漏洞最近在版本 2.4.49 中引入。该项目没有发生已知的漏洞利用。
(CVE-2021-41524)

- 在对 Apache HTTP Server 2.4.49 中的路径规范化进行的更改中发现缺陷。攻击者可利用路径遍历攻击,将 URL 映射到预期文档根目录之外的文件。如果文档根目录以外的文件不受要求的保护,则所有已拒绝的请求都可能会成功。此外,此缺陷可泄露已解释文件(如 CGI 脚本)的来源。已知此问题正在通常环境中被利用。此问题仅影响 Apache 2.4.49 ,而不会影响其之前的版本。(CVE-2021-41773)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级至 Apache 2.4.50 或更高版本。

另见

https://httpd.apache.org/security/vulnerabilities_24.html

插件详情

严重性: High

ID: 153884

文件名: apache_2_4_50.nasl

版本: 1.9

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2021/10/5

最近更新时间: 2021/11/30

依存关系: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

风险信息

CVSS 分数来源: CVE-2021-41773

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: Medium

基本分数: 4.3

时间分数: 3.6

矢量: AV:N/AC:M/Au:N/C:P/I:N/A:N

时间矢量: E:F/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 7

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

时间矢量: E:F/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

可利用: true

易利用性: Exploits are available

补丁发布日期: 2021/10/4

漏洞发布日期: 2021/10/4

可利用的方式

Metasploit (Apache 2.4.49/2.4.50 Traversal RCE)

参考资料信息

CVE: CVE-2021-41524, CVE-2021-41773

IAVA: 2021-A-0451