Apache >= 2.4.30 < 2.4.49 mod_proxy_uwsgi

high Nessus 插件 ID 153586

简介

远程 Web 服务器受到漏洞的影响。

描述

远程主机上安装的 Apache httpd 版本高于 2.4.30 但低于 2.4.49。因此,该应用程序受到 2.4.49 更新日志中提及的一个漏洞的影响。精心构建的请求 uri-path 可导致 mod_proxy_uwsgi 读取超出所分配内存范围的数据并发生崩溃 (DoS)。

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级至 Apache 2.4.49 或更高版本。

另见

https://downloads.apache.org/httpd/CHANGES_2.4

https://httpd.apache.org/security/vulnerabilities_24.html

插件详情

严重性: High

ID: 153586

文件名: apache_mod_proxy_uwsgi_2_4_49.nasl

版本: 1.6

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2021/9/23

最近更新时间: 2022/4/11

支持的传感器: Nessus Agent

风险信息

CVSS 分数来源: CVE-2021-36160

VPR

风险因素: Medium

分数: 4.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: AV:N/AC:L/Au:N/C:N/I:N/A:P

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必需的 KB 项: installed_sw/Apache

易利用性: No known exploits are available

补丁发布日期: 2021/9/16

漏洞发布日期: 2021/9/16

参考资料信息

CVE: CVE-2021-36160

IAVA: 2021-A-0440-S