Drupal 8.9.x < 8.9.18 / 9.1.x < 9.1.12 / 9.2.x < 9.2.4 Drupal 漏洞 (SA-CORE-2021-005)

medium Nessus 插件 ID 152533
全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Web 服务器上运行的 PHP 应用程序受到一个漏洞的影响。

描述

根据其自我报告的版本,远程 Web 服务器上运行的 Drupal 实例为低于 8.9.18 的 8.9.x,低于 9.1.12 的 9.1.x 或低于 9.2.4 的 9.2.x。因此,该操作系统受到漏洞的影响。

- Drupal 项目使用 CKEditor 库进行 WYSIWYG 编辑。CKEditor 已发布影响 Drupal 的安全更新。如果 Drupal 配置为允许使用 CKEditor 库进行 WYSIWYG 编辑,则可能存在漏洞。可创建或编辑内容的攻击者(即使本身没有 CKEditor 的访问权限),可能会利用一个或多个跨站脚本 (XSS) 漏洞来瞄准有权访问 WYSIWYG CKEditor 的用户,包括具有特权访问权限的站点管理员。有关更多信息,请参阅 CKEditor 的版本公告。Drupal Steward 不涵盖此公告。(SA-CORE-2021-005)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级到 Drupal 8.9.18 / 9.1.12 / 9.2.4 或更高版本。

另见

https://www.drupal.org/sa-core-2021-005

http://www.nessus.org/u?03aa81e2

https://github.com/ckeditor/ckeditor4

https://www.drupal.org/project/drupal/releases/8.9.18

https://www.drupal.org/project/drupal/releases/9.1.12

https://www.drupal.org/project/drupal/releases/9.2.4

https://www.drupal.org/psa-2011-002

https://www.drupal.org/steward

插件详情

严重性: Medium

ID: 152533

文件名: drupal_9_2_4.nasl

版本: 1.8

类型: remote

系列: CGI abuses

发布时间: 2021/8/12

最近更新时间: 2021/9/16

依存关系: drupal_detect.nasl

配置: 启用偏执模式

风险信息

CVSS 分数来源: CVE-2021-37695

VPR

风险因素: Low

分数: 3

CVSS v2

风险因素: Low

基本分数: 3.5

时间分数: 2.6

矢量: AV:N/AC:M/Au:S/C:N/I:P/A:N

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: Medium

基本分数: 5.4

时间分数: 4.7

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:drupal:drupal

必需的 KB 项: installed_sw/Drupal, Settings/ParanoidReport

易利用性: No known exploits are available

补丁发布日期: 2021/8/12

漏洞发布日期: 2021/8/12

参考资料信息

CVE: CVE-2021-32808, CVE-2021-32809, CVE-2021-37695

IAVA: 2021-A-0384-S