Amazon Linux 2:grub2 (ALAS-2021-1684)

high Nessus 插件 ID 151799

语言:

全新!插件严重性现在使用 CVSS v3

计算的插件严重性默认已更新为使用 CVSS v3。没有 CVSS v3 分数的插件将回退到 CVSS v2 来计算严重性。可以在设置下拉列表中切换严重性显示首选项。

简介

远程 Amazon Linux 2 主机缺少安全更新。

描述

远程主机上安装的 grub2 版本低于 2.06-2。因此,如公告 ALAS2-2021-1684 所述,该主机受到多个漏洞的影响。

- 在启用安全启动时,如果未正确启用使用 ACPI 命令,会发现版本低于 2.06 的 grub2 中存在一个缺陷。拥有特许访问权的攻击者可利用此缺陷,构建包含代码的辅助系统描述表 (SSDT),以便将 Linux 内核锁定变量内容直接写入内存。在内核进一步加载并执行该表,从而破坏其安全启动锁定后,攻击者可加载未签名的代码。此漏洞最大的威胁在于数据机密性和完整性,以及系统可用性。(CVE-2020-14372)

- 发现版本低于 2.06 的 grub2 中存在一个缺陷。rmmod 实现可卸载用作依赖项的模块,但不检查是否仍加载了任何其他依赖项模块,从而造成释放后使用情形。攻击者可利用此漏洞,执行任意代码或绕过安全启动保护。此漏洞最大的威胁在于数据机密性和完整性,以及系统可用性。(CVE-2020-25632)

- 发现版本低于 2.06 的 grub2 中存在一个缺陷。在 USB 设备初始化期间,读取描述符时极少进行边界检查,并假设 USB 设备提供的是合理的值。如果攻击者适当利用此漏洞,则可触发内存损坏,导致任意代码执行,进而绕过安全启动机制。此漏洞最大的威胁在于数据机密性和完整性,以及系统可用性。(CVE-2020-25647)

- 发现版本低于 2.06 的 grub2 中存在一个缺陷。存在的变量名称在提供的命令行中扩展为其相应的变量内容时,会使用 1kB 堆栈缓冲区进行临时存储,但不会充分检查边界。如果通过特定命令行调用函数,此命令行所引用变量的负载足够大,则可能导致堆栈缓冲区溢出,损坏堆栈帧和控制执行机制,同时还可能避开安全启动保护。此漏洞最大的威胁在于数据机密性和完整性,以及系统可用性。
(CVE-2020-27749)

- 发现版本低于 2.06 的 grub2 中存在一个缺陷。cutmem 命令不遵从安全启动锁定,特权攻击者可利用此漏洞,从内存中删除地址范围,在对 grub 内存布局进行适当分类后,制造机会避开安全启动保护。此漏洞最大的威胁在于数据机密性和完整性,以及系统可用性。(CVE-2020-27779)

- 发现版本低于 2.06 的 grub2 中存在一个缺陷。攻击者可利用选项解析器,通过调用带有大量特定短格式选项的特定命令,造成写入内容超出堆分配缓冲区范围。此漏洞最大的威胁在于数据机密性和完整性,以及系统可用性。(CVE-2021-20225)

- 发现版本低于 2.06 的 grub2 中存在一个缺陷。菜单渲染代码中的 Setparam_prefix() 执行长度计算的前提是,表达引用的单引号需要 3 个字符,但实际需要 4 个字符,攻击者可利用此漏洞,通过每次引用时在输入中损坏一个字节来损坏内存。此漏洞最大的威胁在于数据机密性和完整性,以及系统可用性。(CVE-2021-20233)

请注意,Nessus 尚未测试此问题,而是只依赖于应用程序自我报告的版本号。

解决方案

运行“yum update grub2”以更新系统。

另见

https://alas.aws.amazon.com/AL2/ALAS-2021-1684.html

https://access.redhat.com/security/cve/CVE-2020-14372

https://access.redhat.com/security/cve/CVE-2020-25632

https://access.redhat.com/security/cve/CVE-2020-25647

https://access.redhat.com/security/cve/CVE-2020-27749

https://access.redhat.com/security/cve/CVE-2020-27779

https://access.redhat.com/security/cve/CVE-2021-20225

https://access.redhat.com/security/cve/CVE-2021-20233

插件详情

严重性: High

ID: 151799

文件名: al2_ALAS-2021-1684.nasl

版本: 1.2

类型: local

代理: unix

发布时间: 2021/7/16

最近更新时间: 2021/7/16

依存关系: ssh_get_info.nasl

风险信息

CVSS 分数来源: CVE-2021-20233

VPR

风险因素: High

分数: 7.3

CVSS v2

风险因素: High

基本分数: 7.2

时间分数: 5.3

矢量: AV:L/AC:L/Au:N/C:C/I:C/A:C

时间矢量: E:U/RL:OF/RC:C

CVSS v3

风险因素: High

基本分数: 8.2

时间分数: 7.1

矢量: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

时间矢量: E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:amazon:linux:grub2, p-cpe:/a:amazon:linux:grub2-common, p-cpe:/a:amazon:linux:grub2-debuginfo, p-cpe:/a:amazon:linux:grub2-efi-aa64, p-cpe:/a:amazon:linux:grub2-efi-aa64-cdboot, p-cpe:/a:amazon:linux:grub2-efi-aa64-ec2, p-cpe:/a:amazon:linux:grub2-efi-aa64-modules, p-cpe:/a:amazon:linux:grub2-efi-x64, p-cpe:/a:amazon:linux:grub2-efi-x64-cdboot, p-cpe:/a:amazon:linux:grub2-efi-x64-ec2, p-cpe:/a:amazon:linux:grub2-efi-x64-modules, p-cpe:/a:amazon:linux:grub2-emu, p-cpe:/a:amazon:linux:grub2-emu-modules, p-cpe:/a:amazon:linux:grub2-pc, p-cpe:/a:amazon:linux:grub2-pc-modules, p-cpe:/a:amazon:linux:grub2-tools, p-cpe:/a:amazon:linux:grub2-tools-efi, p-cpe:/a:amazon:linux:grub2-tools-extra, p-cpe:/a:amazon:linux:grub2-tools-minimal, cpe:/o:amazon:linux:2

必需的 KB 项: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

易利用性: No known exploits are available

补丁发布日期: 2021/7/14

漏洞发布日期: 2020/7/30

参考资料信息

CVE: CVE-2020-14372, CVE-2020-25632, CVE-2020-25647, CVE-2020-27749, CVE-2020-27779, CVE-2021-20225, CVE-2021-20233

IAVA: 2020-A-0349

ALAS: 2021-1684